summaryrefslogtreecommitdiff
path: root/gnu/packages/tbb.scm
diff options
context:
space:
mode:
authorng0 <ng0@we.make.ritual.n0.is>2016-09-08 23:04:52 +0000
committerEfraim Flashner <efraim@flashner.co.il>2016-09-12 10:37:39 +0300
commitb6337f30cccd55b6f687f0bd80ef5b32a193f1b1 (patch)
tree1b6eeb063237927cc00b6b83fc207cc89446b16f /gnu/packages/tbb.scm
parent8d4169a1d1a379ce450ca4920eadadd86dd1ef9a (diff)
downloadguix-patches-b6337f30cccd55b6f687f0bd80ef5b32a193f1b1.tar
guix-patches-b6337f30cccd55b6f687f0bd80ef5b32a193f1b1.tar.gz
gnu: tbb: Update to 2017.
* gnu/packages/tbb.scm (tbb): Update to 2017. [license]: Change to ASL2.0. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/tbb.scm')
-rw-r--r--gnu/packages/tbb.scm11
1 files changed, 5 insertions, 6 deletions
diff --git a/gnu/packages/tbb.scm b/gnu/packages/tbb.scm
index 0e9db720aa..c19391abfb 100644
--- a/gnu/packages/tbb.scm
+++ b/gnu/packages/tbb.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2016 ng0 <ng0@we.make.ritual.n0.is>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -27,16 +28,16 @@
(define-public tbb
(package
(name "tbb")
- (version "4.3.2")
+ (version "2017")
(source (origin
(method url-fetch)
(uri (string-append
"https://www.threadingbuildingblocks.org/sites/default"
"/files/software_releases/source/"
- "tbb43_20141204oss_src.tgz"))
+ "tbb" version "_20160722oss_src.tgz"))
(sha256
(base32
- "0jsczl99jfgj47kj7c4sd4fk7v3rbaiax1ng9ypykz1hh0lrrsws"))
+ "038rmv3s8si51bjrzwyv8ldqw742fjjdfayi8pmjaq5zw32b8pzx"))
(modules '((guix build utils)))
(snippet
'(substitute* "build/common.inc"
@@ -85,6 +86,4 @@ the low-level threading details necessary for optimal multi-core performance.
It uses common C++ templates and coding style to eliminate tedious threading
implementation work. It provides parallel loop constructs, asynchronous
tasks, synchronization primitives, atomic operations, and more.")
- ;; GPLv2 with run-time exception:
- ;; <https://www.threadingbuildingblocks.org/licensing#runtime-exception>
- (license gpl2)))
+ (license asl2.0)))