summaryrefslogtreecommitdiff
path: root/gnu/packages/tbb.scm
diff options
context:
space:
mode:
authorSimon South <simon@simonsouth.net>2022-02-02 09:47:05 -0500
committerLudovic Courtès <ludo@gnu.org>2022-02-05 00:59:30 +0100
commit2d4c22b0aa497f8a5e57a453b1dbf3ea98747c5f (patch)
treede4f8a895d2c9cb9832be11c6a4d5198af50d063 /gnu/packages/tbb.scm
parent41efa45508b292d947371dd6b9df943c33727c3d (diff)
downloadguix-patches-2d4c22b0aa497f8a5e57a453b1dbf3ea98747c5f.tar
guix-patches-2d4c22b0aa497f8a5e57a453b1dbf3ea98747c5f.tar.gz
gnu: tbb: Fix test on AArch64.
* gnu/packages/patches/tbb-fix-test-on-aarch64.patch: New file. * gnu/local.mk: Add it. * gnu/packages/tbb.scm (tbb)[source]: Apply it. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/tbb.scm')
-rw-r--r--gnu/packages/tbb.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/tbb.scm b/gnu/packages/tbb.scm
index e5d8394f5f..ef92e6db69 100644
--- a/gnu/packages/tbb.scm
+++ b/gnu/packages/tbb.scm
@@ -41,6 +41,10 @@
(sha256
(base32
"0ih727g802j9lvwkqhw021bk1wb7xlvfgd0vl1i6jng4am1wv7vq"))))
+ (patches (list
+ ;; Backport an upstream commit that prevents the
+ ;; "test_eh_thread" test failing on AArch64.
+ (search-patch "tbb-fix-test-on-aarch64.patch")))))
(build-system cmake-build-system)
(arguments
`(#:configure-flags '("-DTBB_STRICT=OFF"))) ;; Don't fail on warnings