summaryrefslogtreecommitdiff
path: root/gnu/packages/tbb.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-04-27 11:21:08 +0200
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-04-27 15:12:46 +0200
commit02ed8be3acb20eac54086c78829f858184a9fc8c (patch)
tree2fe21443ca7ee2b3d15abe501dc081ccb0d94c2c /gnu/packages/tbb.scm
parent5809ffccc51adce533530a1b1a0d619532e6d741 (diff)
downloadguix-patches-02ed8be3acb20eac54086c78829f858184a9fc8c.tar
guix-patches-02ed8be3acb20eac54086c78829f858184a9fc8c.tar.gz
gnu: tbb: Set rpath in LDFLAGS.
* gnu/packages/tbb.scm (tbb)[arguments]: Set rpath to "/lib" output directory in LDFLAGS.
Diffstat (limited to 'gnu/packages/tbb.scm')
-rw-r--r--gnu/packages/tbb.scm2
1 files changed, 2 insertions, 0 deletions
diff --git a/gnu/packages/tbb.scm b/gnu/packages/tbb.scm
index 3c41141dc6..0e9db720aa 100644
--- a/gnu/packages/tbb.scm
+++ b/gnu/packages/tbb.scm
@@ -46,6 +46,8 @@
(build-system gnu-build-system)
(arguments
`(#:test-target "test"
+ #:make-flags (list (string-append "LDFLAGS=-Wl,-rpath="
+ (assoc-ref %outputs "out") "/lib"))
#:phases (alist-replace
'configure
(lambda* (#:key outputs #:allow-other-keys)