summaryrefslogtreecommitdiff
path: root/gnu/packages/synergy.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-11-10 15:16:54 +0100
committerRicardo Wurmus <rekado@elephly.net>2017-11-10 15:19:06 +0100
commitae451b9dc24839878a0dd7e28815318c662bdb35 (patch)
tree6d7e2218924339b7c2c6e16c58f653c0bf0e232d /gnu/packages/synergy.scm
parent177475cfb5318dbb2ecfd1a1df428c796bec299b (diff)
downloadguix-patches-ae451b9dc24839878a0dd7e28815318c662bdb35.tar
guix-patches-ae451b9dc24839878a0dd7e28815318c662bdb35.tar.gz
gnu: synergy: Fix minor problems with the package definitions.
* gnu/packages/synergy.scm (synergy)[source]: Return #t in the snippet. [arguments]: Let build phases return #t; fix typo in comment. [home-page]: Change to redirection target. [description]: Fix typo.
Diffstat (limited to 'gnu/packages/synergy.scm')
-rw-r--r--gnu/packages/synergy.scm28
1 files changed, 16 insertions, 12 deletions
diff --git a/gnu/packages/synergy.scm b/gnu/packages/synergy.scm
index 310a0f6194..8e863149c3 100644
--- a/gnu/packages/synergy.scm
+++ b/gnu/packages/synergy.scm
@@ -47,13 +47,15 @@
(modules '((guix build utils)))
(snippet
;; Remove ~14MB of unnecessary bundled source and binaries
- '(for-each delete-file-recursively
- `("ext/bonjour"
- "ext/LICENSE (OpenSSL)"
- ,@(find-files "ext" "openssl-.*\\.tar\\.gz")
- "ext/openssl-osx"
- "ext/openssl-win32"
- "ext/openssl-win64")))))
+ '(begin
+ (for-each delete-file-recursively
+ `("ext/bonjour"
+ "ext/LICENSE (OpenSSL)"
+ ,@(find-files "ext" "openssl-.*\\.tar\\.gz")
+ "ext/openssl-osx"
+ "ext/openssl-win32"
+ "ext/openssl-win64"))
+ #t))))
(build-system cmake-build-system)
(native-inputs `(("unzip" ,unzip)))
(inputs
@@ -78,9 +80,10 @@
(for-each
(lambda (f)
(system* unzip "-d" f (string-append f ".zip")))
- '("gmock-1.6.0" "gtest-1.6.0"))))))
+ '("gmock-1.6.0" "gtest-1.6.0"))))
+ #t))
(replace 'check
- ;; Don't run "integtests" as it requires network and X an display.
+ ;; Don't run "integtests" as it requires network and an X display.
(lambda _
(zero? (system* (string-append srcdir "/bin/unittests")))))
(replace 'install
@@ -103,11 +106,12 @@
(install-file (string-append srcdir "/doc/" e) ex))
'("synergy.conf.example"
"synergy.conf.example-advanced"
- "synergy.conf.example-basic"))))))))))
- (home-page "http://symless.com/")
+ "synergy.conf.example-basic"))))
+ #t))))))
+ (home-page "https://symless.com/synergy")
(synopsis "Mouse and keyboard sharing utility")
(description
- "Synergy brings your computers together in one cohesive experience; its
+ "Synergy brings your computers together in one cohesive experience; it's
software for sharing one mouse and keyboard between multiple computers on your
desk.")
(license gpl2)))