summaryrefslogtreecommitdiff
path: root/gnu/packages/synergy.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-05-27 15:54:10 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-05-27 15:54:10 +0300
commita3025a449011ebe404e27ebfc28669024d6665b4 (patch)
treec880d6bc2fd5972f4734d3e9efda244aecfe399b /gnu/packages/synergy.scm
parentcecaee420ed0cf451c3d4d01dc15db62bbd18de8 (diff)
downloadguix-patches-a3025a449011ebe404e27ebfc28669024d6665b4.tar
guix-patches-a3025a449011ebe404e27ebfc28669024d6665b4.tar.gz
gnu: synergy: Use 'modify-phases'.
* gnu/packages/synergy.scm (synergy)[arguments]; Use 'modify-phases'.
Diffstat (limited to 'gnu/packages/synergy.scm')
-rw-r--r--gnu/packages/synergy.scm39
1 files changed, 18 insertions, 21 deletions
diff --git a/gnu/packages/synergy.scm b/gnu/packages/synergy.scm
index 8b53660fce..47fb57f606 100644
--- a/gnu/packages/synergy.scm
+++ b/gnu/packages/synergy.scm
@@ -66,25 +66,23 @@
(arguments
`(#:phases
(let ((srcdir (string-append "../synergy-" ,version "-stable")))
- (alist-cons-before
- 'configure 'unpack-aux-src
- ;; TODO: package and use from system
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((unzip (string-append
- (assoc-ref inputs "unzip")
- "/bin/unzip")))
- (with-directory-excursion "ext"
- (for-each
- (lambda (f)
- (system* unzip "-d" f (string-append f ".zip")))
- '("gmock-1.6.0" "gtest-1.6.0")))))
- (alist-replace
- 'check
- ;; Don't run "integtests" as it requires network and X an display.
- (lambda _
- (zero? (system* (string-append srcdir "/bin/unittests"))))
- (alist-replace
- 'install
+ (modify-phases %standard-phases
+ (add-before 'configure 'unpack-aux-src
+ ;; TODO: package and use from system
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((unzip (string-append
+ (assoc-ref inputs "unzip")
+ "/bin/unzip")))
+ (with-directory-excursion "ext"
+ (for-each
+ (lambda (f)
+ (system* unzip "-d" f (string-append f ".zip")))
+ '("gmock-1.6.0" "gtest-1.6.0"))))))
+ (replace 'check
+ ;; Don't run "integtests" as it requires network and X an display.
+ (lambda _
+ (zero? (system* (string-append srcdir "/bin/unittests")))))
+ (replace 'install
;; There currently is no installation process, see:
;; http://synergy-project.org/spit/issues/details/3317/
(lambda* (#:key outputs #:allow-other-keys)
@@ -104,8 +102,7 @@
(install-file (string-append srcdir "/doc/" e) ex))
'("synergy.conf.example"
"synergy.conf.example-advanced"
- "synergy.conf.example-basic")))))
- %standard-phases))))))
+ "synergy.conf.example-basic"))))))))))
(home-page "http://symless.com/")
(synopsis "Mouse and keyboard sharing utility")
(description