summaryrefslogtreecommitdiff
path: root/gnu/packages/syndication.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-10-10 12:29:16 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-10-10 12:31:31 +0300
commitedbcbdabac9a64dba3850b0f7e596b396f044599 (patch)
tree39b6978d341998dd049e142c55ab79e7b63a7c64 /gnu/packages/syndication.scm
parente0363d7dbc53c3f27cc4b45379263ae69af7fefe (diff)
downloadguix-patches-edbcbdabac9a64dba3850b0f7e596b396f044599.tar
guix-patches-edbcbdabac9a64dba3850b0f7e596b396f044599.tar.gz
gnu: newsboat: Update to 2.25.
* gnu/packages/syndication.scm (newsboat): Update to 2.25. [arguments]: Increase run version to 1.51. [cargo-inputs]: Replace rust-bitflags-1 with 1.3, rust-nom-6 with 7. Remove rust-rand-0.8, add rust-fastrand-1. [cargo-development-inputs]: Replace rust-proptest-0.9 with 1.
Diffstat (limited to 'gnu/packages/syndication.scm')
-rw-r--r--gnu/packages/syndication.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/syndication.scm b/gnu/packages/syndication.scm
index 128e4ba00e..fef315c5b9 100644
--- a/gnu/packages/syndication.scm
+++ b/gnu/packages/syndication.scm
@@ -217,14 +217,14 @@ cards.")
(define-public newsboat
(package
(name "newsboat")
- (version "2.24")
+ (version "2.25")
(source
(origin
(method url-fetch)
(uri (string-append "https://newsboat.org/releases/" version
"/newsboat-" version ".tar.xz"))
(sha256
- (base32 "1yvggkb29qykxlvrysb6yyf5piwsvzv0zla8jn2ihmm2rj40chk2"))))
+ (base32 "0zh1lqgsfhz8cmn6ajvcrfbn9iq2ls3adi2g17syzj8xiwvspaj1"))))
(build-system cargo-build-system)
(native-inputs
`(("gettext" ,gettext-minimal)
@@ -244,29 +244,29 @@ cards.")
(guix build utils)
((guix build gnu-build-system) #:prefix gnu:))
#:vendor-dir "vendor"
- #:rust ,rust-1.48 ; or newer
+ #:rust ,rust-1.51 ; or newer
#:install-source? #f
#:cargo-inputs
(("rust-backtrace" ,rust-backtrace-0.3)
- ("rust-bitflags" ,rust-bitflags-1)
+ ("rust-bitflags" ,rust-bitflags-1.3)
("rust-chrono" ,rust-chrono-0.4)
("rust-clap" ,rust-clap-2)
("rust-curl-sys" ,rust-curl-sys-0.4)
("rust-cxx" ,rust-cxx-1)
+ ("rust-fastrand" ,rust-fastrand-1)
("rust-gettext-rs" ,rust-gettext-rs-0.7)
("rust-libc" ,rust-libc-0.2)
("rust-natord" ,rust-natord-1)
- ("rust-nom" ,rust-nom-6)
+ ("rust-nom" ,rust-nom-7)
("rust-once-cell" ,rust-once-cell-1)
("rust-percent-encoding" ,rust-percent-encoding-2)
- ("rust-rand" ,rust-rand-0.8)
("rust-url" ,rust-url-2)
("rust-unicode-width" ,rust-unicode-width-0.1)
("rust-xdg" ,rust-xdg-2))
#:cargo-development-inputs
(("rust-cxx-build" ,rust-cxx-build-1)
("rust-tempfile" ,rust-tempfile-3)
- ("rust-proptest" ,rust-proptest-0.9)
+ ("rust-proptest" ,rust-proptest-1)
("rust-section-testing" ,rust-section-testing-0.0))
#:phases
(modify-phases %standard-phases