summaryrefslogtreecommitdiff
path: root/gnu/packages/syndication.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-08-18 16:33:04 -0400
committerLeo Famulari <leo@famulari.name>2017-08-18 17:24:47 -0400
commitd9f15d7e48bc7c361b8a88849542d9f5d7442126 (patch)
tree97996630ff568474c4d32bd426292bb8ca87fb9b /gnu/packages/syndication.scm
parent8c0c0c4defed40f4cb3139e0a887f9ed19915b1b (diff)
downloadguix-patches-d9f15d7e48bc7c361b8a88849542d9f5d7442126.tar
guix-patches-d9f15d7e48bc7c361b8a88849542d9f5d7442126.tar.gz
gnu: newsbeuter: Fix CVE-2017-12904.
* gnu/packages/patches/newsbeuter-CVE-2017-12904.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/syndication.scm (newsbeuter)[source]: Use it.
Diffstat (limited to 'gnu/packages/syndication.scm')
-rw-r--r--gnu/packages/syndication.scm2
1 files changed, 2 insertions, 0 deletions
diff --git a/gnu/packages/syndication.scm b/gnu/packages/syndication.scm
index f434006656..80c45c396c 100644
--- a/gnu/packages/syndication.scm
+++ b/gnu/packages/syndication.scm
@@ -18,6 +18,7 @@
#:use-module (guix download)
#:use-module (guix packages)
#:use-module (guix build-system gnu)
+ #:use-module (gnu packages)
#:use-module (gnu packages curl)
#:use-module (gnu packages databases)
#:use-module (gnu packages gettext)
@@ -37,6 +38,7 @@
(method url-fetch)
(uri (string-append "https://newsbeuter.org/downloads/newsbeuter-"
version ".tar.gz"))
+ (patches (search-patches "newsbeuter-CVE-2017-12904.patch"))
(sha256
(base32
"1j1x0hgwxz11dckk81ncalgylj5y5fgw5bcmp9qb5hq9kc0vza3l"))))