summaryrefslogtreecommitdiff
path: root/gnu/packages/syndication.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-08-04 15:15:57 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-08-04 15:15:57 +0300
commita715e93a095a413a7f09d41ae5b315be39a9abda (patch)
treea9a609fb08c50ee4fc757587a4bb5c738703c9bd /gnu/packages/syndication.scm
parent75ec0fa243c5d97ee51deadf3703e10f6f8459fe (diff)
downloadguix-patches-a715e93a095a413a7f09d41ae5b315be39a9abda.tar
guix-patches-a715e93a095a413a7f09d41ae5b315be39a9abda.tar.gz
gnu: tuir: Respect #:tests?.
* gnu/packages/syndication.scm (tuir)[arguments]: Adjust custom 'check phase to skip tests when requested.
Diffstat (limited to 'gnu/packages/syndication.scm')
-rw-r--r--gnu/packages/syndication.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/syndication.scm b/gnu/packages/syndication.scm
index f3690a1a29..2f3f191a47 100644
--- a/gnu/packages/syndication.scm
+++ b/gnu/packages/syndication.scm
@@ -475,9 +475,10 @@ a simple interface that makes it easy to organize and browse feeds.")
`(#:phases
(modify-phases %standard-phases
(replace 'check
- (lambda* (#:key inputs outputs #:allow-other-keys)
+ (lambda* (#:key tests? inputs outputs #:allow-other-keys)
(add-installed-pythonpath inputs outputs)
- (invoke "pytest"))))))
+ (when tests?
+ (invoke "pytest")))))))
(inputs
`(("python-beautifulsoup4" ,python-beautifulsoup4)
("python-decorator" ,python-decorator)