summaryrefslogtreecommitdiff
path: root/gnu/packages/syndication.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-07-08 10:53:45 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-07-08 10:55:30 +0300
commit94f772dad8cb1064d0e8cf11285ad9963ba00224 (patch)
tree03f1853d46ce0cde83f1695ba2246bd404907a7f /gnu/packages/syndication.scm
parentf28f095fbd30a0a6379dcc6f052cd426639065be (diff)
downloadguix-patches-94f772dad8cb1064d0e8cf11285ad9963ba00224.tar
guix-patches-94f772dad8cb1064d0e8cf11285ad9963ba00224.tar.gz
gnu: newsboat: Update to 2.24.
* gnu/packages/syndication.scm (newsboat): Update to 2.24. [arguments]: Update rust to 1.48. [cargo-inputs]: Replace rust-cxx-0.5 with 1, rust-gettext-rs-0.6 with 0.7. [cargo-development-inputs]: Replace rust-cxx-build-0.5 with 1.
Diffstat (limited to 'gnu/packages/syndication.scm')
-rw-r--r--gnu/packages/syndication.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/syndication.scm b/gnu/packages/syndication.scm
index 4d7d803b72..f3690a1a29 100644
--- a/gnu/packages/syndication.scm
+++ b/gnu/packages/syndication.scm
@@ -219,14 +219,14 @@ cards.")
(define-public newsboat
(package
(name "newsboat")
- (version "2.23")
+ (version "2.24")
(source
(origin
(method url-fetch)
(uri (string-append "https://newsboat.org/releases/" version
"/newsboat-" version ".tar.xz"))
(sha256
- (base32 "1p6sqypgzhwirgljr898c9n7vr5y9322fvrlaigwrchxshwv35xr"))))
+ (base32 "1yvggkb29qykxlvrysb6yyf5piwsvzv0zla8jn2ihmm2rj40chk2"))))
(build-system cargo-build-system)
(native-inputs
`(("gettext" ,gettext-minimal)
@@ -246,7 +246,7 @@ cards.")
(guix build utils)
((guix build gnu-build-system) #:prefix gnu:))
#:vendor-dir "vendor"
- #:rust ,rust-1.46 ; or newer
+ #:rust ,rust-1.48 ; or newer
#:install-source? #f
#:cargo-inputs
(("rust-backtrace" ,rust-backtrace-0.3)
@@ -254,8 +254,8 @@ cards.")
("rust-chrono" ,rust-chrono-0.4)
("rust-clap" ,rust-clap-2)
("rust-curl-sys" ,rust-curl-sys-0.4)
- ("rust-cxx" ,rust-cxx-0.5)
- ("rust-gettext-rs" ,rust-gettext-rs-0.6)
+ ("rust-cxx" ,rust-cxx-1)
+ ("rust-gettext-rs" ,rust-gettext-rs-0.7)
("rust-libc" ,rust-libc-0.2)
("rust-natord" ,rust-natord-1)
("rust-nom" ,rust-nom-6)
@@ -266,7 +266,7 @@ cards.")
("rust-unicode-width" ,rust-unicode-width-0.1)
("rust-xdg" ,rust-xdg-2))
#:cargo-development-inputs
- (("rust-cxx-build" ,rust-cxx-build-0.5)
+ (("rust-cxx-build" ,rust-cxx-build-1)
("rust-tempfile" ,rust-tempfile-3)
("rust-proptest" ,rust-proptest-0.9)
("rust-section-testing" ,rust-section-testing-0.0))