summaryrefslogtreecommitdiff
path: root/gnu/packages/syndication.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-03-25 22:57:19 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-03-25 22:57:19 +0200
commit7240b4a989ef9be2fba518666c6213d2eabac394 (patch)
tree5866b2f982a1ea872b2f0fe67618153ba8d6bf8d /gnu/packages/syndication.scm
parent171e84d63d9e51c25c77430db86c80878fc39e3d (diff)
downloadguix-patches-7240b4a989ef9be2fba518666c6213d2eabac394.tar
guix-patches-7240b4a989ef9be2fba518666c6213d2eabac394.tar.gz
gnu: newsboat: Update to 2.11.
* gnu/packages/syndication.scm (newsboat): Update to 2.11. [inputs]: Change from JSON-C-0.12 to JSON-C. [native-search-paths]: New field.
Diffstat (limited to 'gnu/packages/syndication.scm')
-rw-r--r--gnu/packages/syndication.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/syndication.scm b/gnu/packages/syndication.scm
index 3e0cbe832a..1669f2c45c 100644
--- a/gnu/packages/syndication.scm
+++ b/gnu/packages/syndication.scm
@@ -32,7 +32,7 @@
(define-public newsboat
(package
(name "newsboat")
- (version "2.10.2")
+ (version "2.11")
(source
(origin
(method url-fetch)
@@ -40,7 +40,7 @@
"/newsboat-" version ".tar.xz"))
(sha256
(base32
- "1x4nxx1kvmrcm8jy73dvg56h4z15y3sach2vr13cw8rsbi7v99px"))))
+ "0yh1qdk15s9k4pffiw1155whfckpffq72dpyp9rck7yxgy5ya1hx"))))
(build-system gnu-build-system)
(native-inputs
`(("gettext" ,gettext-minimal)
@@ -49,7 +49,7 @@
("asciidoc" ,asciidoc)))
(inputs
`(("curl" ,curl)
- ("json-c" ,json-c-0.12) ; check whether json-c-0.12 can be removed
+ ("json-c" ,json-c)
("libxml2" ,libxml2)
("ncurses" ,ncurses)
("stfl" ,stfl)
@@ -64,6 +64,9 @@
#:make-flags
(list (string-append "prefix=" (assoc-ref %outputs "out")))
#:test-target "test"))
+ (native-search-paths
+ ;; Newsboat respects CURL_CA_BUNDLE.
+ (package-native-search-paths curl))
(home-page "https://newsboat.org/")
(synopsis "Text-mode RSS and Atom feed reader with podcast support")
(description "Newsboat is a feed reader for @dfn{RSS} and @dfn{Atom}, XML