summaryrefslogtreecommitdiff
path: root/gnu/packages/syndication.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-03-24 15:28:33 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-03-24 20:50:44 +0200
commit2aab587f842908a886e3bd08b028885dddd650e0 (patch)
tree87c0723a9ae2c69ab6920d90b6e87ad8510492fe /gnu/packages/syndication.scm
parent5664bcdcb0e4c10dfe48dd5e4730fc3c746a21e2 (diff)
parent65c46e79e0495fe4d32f6f2725d7233fff10fd70 (diff)
downloadguix-patches-2aab587f842908a886e3bd08b028885dddd650e0.tar
guix-patches-2aab587f842908a886e3bd08b028885dddd650e0.tar.gz
Merge remote-tracking branch 'origin/master' into core-updates
Diffstat (limited to 'gnu/packages/syndication.scm')
-rw-r--r--gnu/packages/syndication.scm68
1 files changed, 67 insertions, 1 deletions
diff --git a/gnu/packages/syndication.scm b/gnu/packages/syndication.scm
index f34a59ac17..e4915b2496 100644
--- a/gnu/packages/syndication.scm
+++ b/gnu/packages/syndication.scm
@@ -24,10 +24,11 @@
#:use-module (guix git-download)
#:use-module (guix packages)
#:use-module (guix build-system cargo)
- #:use-module (guix build-system qt)
#:use-module (guix build-system glib-or-gtk)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system meson)
#:use-module (guix build-system python)
+ #:use-module (guix build-system qt)
#:use-module (gnu packages)
#:use-module (gnu packages autotools)
#:use-module (gnu packages base)
@@ -50,7 +51,9 @@
#:use-module (gnu packages qt)
#:use-module (gnu packages ruby)
#:use-module (gnu packages sqlite)
+ #:use-module (gnu packages time)
#:use-module (gnu packages tls)
+ #:use-module (gnu packages video)
#:use-module (gnu packages web)
#:use-module (gnu packages webkit)
#:use-module (gnu packages xml)
@@ -87,6 +90,7 @@
(guix build utils)
((guix build gnu-build-system) #:prefix gnu:))
#:vendor-dir "vendor"
+ #:install-source? #f
#:cargo-inputs
(("rust-backtrace" ,rust-backtrace-0.3)
("rust-bitflags" ,rust-bitflags-1)
@@ -415,3 +419,65 @@ formats, including all versions of RSS and Atom.")
(description "QuiteRSS is an RSS/Atom news feeds reader written on Qt/C++
that aims to be quite fast and comfortable to it's user.")
(license license:gpl3+)))
+
+(define-public gfeeds
+ (package
+ (name "gfeeds")
+ (version "0.16.2")
+ (source (origin
+ (method url-fetch)
+ (uri
+ (string-append
+ "https://gitlab.gnome.org/World/gfeeds/-/archive/" version
+ "/gfeeds-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "05gwwzqfz29m477imd5vh84jfla1wnklwpc2sdxnqli72wg08fli"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-mpv-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "gfeeds/confManager.py"
+ (("mpv") (string-append (assoc-ref inputs "mpv") "/bin/mpv")))
+ #t))
+ (add-after 'install 'wrap-gfeeds
+ (lambda* (#:key outputs #:allow-other-keys)
+ (wrap-program (string-append
+ (assoc-ref outputs "out") "/bin/gfeeds")
+ `("PYTHONPATH" ":" prefix (,(getenv "PYTHONPATH")))
+ `("GI_TYPELIB_PATH" ":" prefix (,(getenv "GI_TYPELIB_PATH")))
+ `("XDG_DATA_DIRS" ":" prefix (,(getenv "XDG_DATA_DIRS"))))
+ #t)))))
+ (native-inputs
+ `(("glib:bin" ,glib "bin")
+ ("gobject-introspection" ,gobject-introspection)
+ ("gtk+:bin" ,gtk+ "bin")
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("glib" ,glib)
+ ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
+ ("gtk+" ,gtk+)
+ ("hicolor-icon-theme" ,hicolor-icon-theme)
+ ("libhandy" ,libhandy)
+ ("mpv" ,mpv)
+ ("python" ,python)
+ ("python-beautifulsoup4" ,python-beautifulsoup4)
+ ("python-dateutil" ,python-dateutil)
+ ("python-feedparser" ,python-feedparser)
+ ("python-html5lib" ,python-html5lib)
+ ("python-listparser" ,python-listparser)
+ ("python-lxml" ,python-lxml)
+ ("python-pillow" ,python-pillow)
+ ("python-pygments" ,python-pygments)
+ ("python-pytz" ,python-pytz)
+ ("python-readability" ,python-readability)
+ ("python-requests" ,python-requests)
+ ("webkitgtk" ,webkitgtk)
+ ("python-pygobject" ,python-pygobject)))
+ (home-page "https://gfeeds.gabmus.org/")
+ (synopsis "Easy-to-use GTK+ RSS/Atom feed reader")
+ (description "Feeds is an RSS/Atom feed reader made with GTK+
+and it has an easy-to-use graphical user interface.")
+ (license license:gpl3+)))