summaryrefslogtreecommitdiff
path: root/gnu/packages/syndication.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-11-10 10:22:47 +0200
committerEfraim Flashner <efraim@flashner.co.il>2016-11-12 20:50:48 +0200
commit15abcabe4e1d34416714eae66dba32ff96d05a6f (patch)
tree1039d402503d74f9c66faba52c6b782ec7b40bdf /gnu/packages/syndication.scm
parentc76dab7b36856dffd984091a6b7b6319b69e1aa4 (diff)
downloadguix-patches-15abcabe4e1d34416714eae66dba32ff96d05a6f.tar
guix-patches-15abcabe4e1d34416714eae66dba32ff96d05a6f.tar.gz
gnu: Add newsbeuter.
* gnu/packages/syndication.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add it.
Diffstat (limited to 'gnu/packages/syndication.scm')
-rw-r--r--gnu/packages/syndication.scm75
1 files changed, 75 insertions, 0 deletions
diff --git a/gnu/packages/syndication.scm b/gnu/packages/syndication.scm
new file mode 100644
index 0000000000..f4668de0c0
--- /dev/null
+++ b/gnu/packages/syndication.scm
@@ -0,0 +1,75 @@
+;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages syndication)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix download)
+ #:use-module (guix packages)
+ #:use-module (guix build-system gnu)
+ #:use-module (gnu packages curl)
+ #:use-module (gnu packages databases)
+ #:use-module (gnu packages gettext)
+ #:use-module (gnu packages ncurses)
+ #:use-module (gnu packages perl)
+ #:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages ruby)
+ #:use-module (gnu packages xml)
+ #:use-module (gnu packages web))
+
+(define-public newsbeuter
+ (package
+ (name "newsbeuter")
+ (version "2.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://newsbeuter.org/downloads/newsbeuter-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1j1x0hgwxz11dckk81ncalgylj5y5fgw5bcmp9qb5hq9kc0vza3l"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda _
+ (substitute* "config.sh"
+ ;; try to remove this at the next release
+ (("ncursesw5") "ncursesw6"))
+ #t)))
+ #:make-flags (list (string-append "prefix=" (assoc-ref %outputs "out")))
+ #:test-target "test"))
+ (native-inputs
+ `(("gettext" ,gnu-gettext)
+ ("perl" ,perl)
+ ("pkg-config" ,pkg-config)
+ ("ruby" ,ruby))) ; for tests
+ (inputs
+ `(("curl" ,curl)
+ ("json-c" ,json-c)
+ ("ncurses" ,ncurses)
+ ("stfl" ,stfl)
+ ("sqlite" ,sqlite)
+ ("libxml2" ,libxml2)))
+ (home-page "https://newsbeuter.org/")
+ (synopsis "Text mode rss feed reader with podcast support")
+ (description "Newsbeuter is an innovative RSS feed reader for the text
+console. It supports OPML import/exports, HTML rendering, podcast (podbeuter),
+offline reading, searching and storing articles to your filesystem, and many
+more features. Its user interface is coherent, easy to use, and might look
+common to users of @command{mutt} and @command{slrn}.")
+ (license (list license:gpl2+ ; filter/*
+ license:x11))))