summaryrefslogtreecommitdiff
path: root/gnu/packages/syncthing.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2019-03-06 15:50:44 -0500
committerLeo Famulari <leo@famulari.name>2019-03-14 15:34:28 -0400
commitd73cbbda3e74ff6dc23ce5882130d126d24ecd13 (patch)
tree0d584c0f16861e6d899e8f037338136e9bb9ae49 /gnu/packages/syncthing.scm
parentac51900dfdef2e6d293d81a55c80426f27e04705 (diff)
downloadguix-patches-d73cbbda3e74ff6dc23ce5882130d126d24ecd13.tar
guix-patches-d73cbbda3e74ff6dc23ce5882130d126d24ecd13.tar.gz
gnu: go-github-com-lib-pq: Update to 1.0.0.
* gnu/packages/syncthing.scm (go-github-com-lib-pq): Update to 1.0.0.
Diffstat (limited to 'gnu/packages/syncthing.scm')
-rw-r--r--gnu/packages/syncthing.scm46
1 files changed, 22 insertions, 24 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 3dfb50ee94..74479e7a08 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -338,31 +338,29 @@ address of the default LAN gateway.")
(license bsd-3))))
(define-public go-github-com-lib-pq
- (let ((commit "83612a56d3dd153a94a629cd64925371c9adad78")
- (revision "1"))
- (package
- (name "go-github-com-lib-pq")
- (version (git-version "0.0.0" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/lib/pq")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "12334yigh284k5cdvb9pgxaq6n78205jcbp75ajz44vvfd4wi6qc"))))
- (build-system go-build-system)
- (arguments
- `(#:import-path "github.com/lib/pq"
- ;; The tests seem to fail without access to the network or a running
- ;; Postgres instance.
- #:tests? #f))
- (synopsis "Golang Postgres driver for Go's database/sql")
- (description "This packages provides a pure Go Postgres driver for Go's
+ (package
+ (name "go-github-com-lib-pq")
+ (version "1.0.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/lib/pq")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1zqnnyczaf00xi6xh53vq758v5bdlf0iz7kf22l02cal4i6px47i"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/lib/pq"
+ ;; The tests seem to fail without access to the network or a running
+ ;; Postgres instance.
+ #:tests? #f))
+ (synopsis "Golang Postgres driver for Go's database/sql")
+ (description "This packages provides a pure Go Postgres driver for Go's
database/sql package.")
- (home-page "https://github.com/lib/pq")
- (license expat))))
+ (home-page "https://github.com/lib/pq")
+ (license expat)))
(define-public go-github-com-oschwald-geoip2-golang
(package