summaryrefslogtreecommitdiff
path: root/gnu/packages/syncthing.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2019-09-02 21:03:52 -0400
committerLeo Famulari <leo@famulari.name>2019-09-05 11:09:36 -0400
commitd5508458406fcd8c95289afb3097ab951173827f (patch)
treed9eaa2a2472ad88e9a89e2528b5bb46a8c5f1a6c /gnu/packages/syncthing.scm
parent9a2f23341d8f916217b759c58f5a487e656723fd (diff)
downloadguix-patches-d5508458406fcd8c95289afb3097ab951173827f.tar
guix-patches-d5508458406fcd8c95289afb3097ab951173827f.tar.gz
gnu: Syncthing: Update to 1.2.2.
* gnu/packages/syncthing.scm (syncthing): Update to 1.2.2. [inputs]: Remove go-github-com-calmh-du and add go-github-com-shirou-gopsutil.
Diffstat (limited to 'gnu/packages/syncthing.scm')
-rw-r--r--gnu/packages/syncthing.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 0f81b8804a..74457f6ec4 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -30,7 +30,7 @@
(define-public syncthing
(package
(name "syncthing")
- (version "1.2.1")
+ (version "1.2.2")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/syncthing/syncthing"
@@ -38,7 +38,7 @@
"/syncthing-source-v" version ".tar.gz"))
(sha256
(base32
- "1b6fidpkwfa2bm6hlv4p0bzxa1ha6s88vajczhryhqi5vjfxafri"))
+ "1wdjh8xw09s1nfkpc95v04619gqa4dpbygp2y5l35ww4g916lv3s"))
(modules '((guix build utils)))
;; Delete bundled ("vendored") free software source code.
(snippet '(begin
@@ -55,7 +55,6 @@
`(("go-github-com-audriusbutkevicius-go-nat-pmp"
,go-github-com-audriusbutkevicius-go-nat-pmp)
("go-github-com-bkaradzic-go-lz4" ,go-github-com-bkaradzic-go-lz4)
- ("go-github-com-calmh-du" ,go-github-com-calmh-du)
("go-github-com-calmh-xdr" ,go-github-com-calmh-xdr)
("go-github-com-chmduquesne-rollinghash"
,go-github-com-chmduquesne-rollinghash)
@@ -84,6 +83,7 @@
,go-github-com-gogo-protobuf-protoc-gen-gogo)
("go-github-com-prometheus-client-golang-prometheus"
,go-github-com-prometheus-client-golang-prometheus)
+ ("go-github-com-shirou-gopsutil" ,go-github-com-shirou-gopsutil)
("go-golang-org-x-net-bpf" ,go-golang-org-x-net-bpf)
("go-golang-org-x-net-internal-iana" ,go-golang-org-x-net-internal-iana)
("go-golang-org-x-net-internal-socket"