summaryrefslogtreecommitdiff
path: root/gnu/packages/syncthing.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2019-03-06 15:40:48 -0500
committerLeo Famulari <leo@famulari.name>2019-03-14 15:34:27 -0400
commitc36177c69873c32b617e12a44e8f084f0dea3a2a (patch)
treeff02c12ced6025d3d1f0e907e8559c61466767ab /gnu/packages/syncthing.scm
parent061387ea322b16ee28ef192c1f9e0b413097db8b (diff)
downloadguix-patches-c36177c69873c32b617e12a44e8f084f0dea3a2a.tar
guix-patches-c36177c69873c32b617e12a44e8f084f0dea3a2a.tar.gz
gnu: go-github-com-pkg-errors: Update to 0.8.1.
* gnu/packages/syncthing.scm (go-github-com-pkg-errors): Update to 0.8.1.
Diffstat (limited to 'gnu/packages/syncthing.scm')
-rw-r--r--gnu/packages/syncthing.scm40
1 files changed, 19 insertions, 21 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index b5ee59db71..7e61d5ee89 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -691,28 +691,26 @@ rolling hash.")
(license expat))))
(define-public go-github-com-pkg-errors
- (let ((commit "e881fd58d78e04cf6d0de1217f8707c8cc2249bc")
- (revision "1"))
- (package
- (name "go-github-com-pkg-errors")
- (version (git-version "0.0.0" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/pkg/errors.git")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0vfhj598jp6dzy4pbyjdrqxzb5kppw8ggvfh78g80nz11r34xnzs"))))
- (build-system go-build-system)
- (arguments
- `(#:import-path "github.com/pkg/errors"))
- (synopsis "Go error handling primitives")
- (description "This packages provides @code{error}, which offers simple
+ (package
+ (name "go-github-com-pkg-errors")
+ (version "0.8.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pkg/errors.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0g5qcb4d4fd96midz0zdk8b9kz8xkzwfa8kr1cliqbg8sxsy5vd1"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/pkg/errors"))
+ (synopsis "Go error handling primitives")
+ (description "This packages provides @code{error}, which offers simple
error handling primitives in Go.")
- (home-page "https://github.com/pkg/errors")
- (license bsd-2))))
+ (home-page "https://github.com/pkg/errors")
+ (license bsd-2)))
(define-public go-github-com-petermattis-goid
(let ((commit "3db12ebb2a599ba4a96bea1c17b61c2f78a40e02")