summaryrefslogtreecommitdiff
path: root/gnu/packages/syncthing.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-12-06 14:04:30 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-12-06 14:04:30 +0200
commitb6a726222a8ef3bfe46402a46b15d79c6b19b6d6 (patch)
tree25be31451b26113295ca920317105320a0ebc43e /gnu/packages/syncthing.scm
parent9478a252509a93f3e7f486cbc549631185ba071d (diff)
downloadguix-patches-b6a726222a8ef3bfe46402a46b15d79c6b19b6d6.tar
guix-patches-b6a726222a8ef3bfe46402a46b15d79c6b19b6d6.tar.gz
gnu: go-github-com-golang-snappy: Adjust test-suite on 32-bit systems.
* gnu/packages/syncthing.scm (go-github-com-golang-snappy)[source]: Add patch to skip a test on 32-bit systems. * gnu/packages/patches/go-github-com-golang-snappy-32bit-test.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it.
Diffstat (limited to 'gnu/packages/syncthing.scm')
-rw-r--r--gnu/packages/syncthing.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 4deb60bee2..aa718e5e2d 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -412,7 +412,8 @@ processes.")
(file-name (git-file-name name version))
(sha256
(base32
- "004cw699yz3pdpawhjhpa0y94c4w479nw1rf39zj6h6027kpwv2j"))))
+ "004cw699yz3pdpawhjhpa0y94c4w479nw1rf39zj6h6027kpwv2j"))
+ (patches (search-patches "go-github-com-golang-snappy-32bit-test.patch"))))
(build-system go-build-system)
(arguments
`(#:import-path "github.com/golang/snappy"))