summaryrefslogtreecommitdiff
path: root/gnu/packages/syncthing.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-04-26 21:28:18 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-04-26 21:32:49 +0300
commit9c8a108186fa23cf31bf3a1a2370c4f82bdc91e3 (patch)
tree27af3fc2bf4f9d648bd4191f36d1ff9fa1fa37e8 /gnu/packages/syncthing.scm
parent43a7724040560d35e9e3a19bd1cfdb7e5c4c4711 (diff)
downloadguix-patches-9c8a108186fa23cf31bf3a1a2370c4f82bdc91e3.tar
guix-patches-9c8a108186fa23cf31bf3a1a2370c4f82bdc91e3.tar.gz
gnu: syncthing: Allow skipping the check phase.
* gnu/packages/syncthing.scm (syncthing)[arguments]: Adjust the custom 'check phase so tests only run when enabled.
Diffstat (limited to 'gnu/packages/syncthing.scm')
-rw-r--r--gnu/packages/syncthing.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index e800aebda7..469c19f109 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2016 Petter <petter@mykolab.ch>
;;; Copyright © 2016, 2017, 2018, 2019, 2020, 2021 Leo Famulari <leo@famulari.name>
;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
-;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;;
@@ -87,9 +87,11 @@
(invoke "go" "run" "build.go" "-no-upgrade" "build" "syncthing"))))
(replace 'check
- (lambda _
- (with-directory-excursion "src/github.com/syncthing/syncthing"
- (invoke "go" "run" "build.go" "test"))))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (with-directory-excursion "src/github.com/syncthing/syncthing"
+ (invoke "go" "run" "build.go" "test")))
+ #t))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)