summaryrefslogtreecommitdiff
path: root/gnu/packages/syncthing.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-06-23 18:56:52 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-06-23 19:17:32 +0300
commit87e1a1979b2bc0fbcd6187483d5e380e3f52d8f5 (patch)
tree4e07f0478d9fe78a61edd5ac5f9470b55bbd785d /gnu/packages/syncthing.scm
parent362ae4313ebdb56223a8ed5511437b59f7876c22 (diff)
downloadguix-patches-87e1a1979b2bc0fbcd6187483d5e380e3f52d8f5.tar
guix-patches-87e1a1979b2bc0fbcd6187483d5e380e3f52d8f5.tar.gz
gnu: go-github-com-rcrowley-go-metrics: Skip tests on aarch64-linux.
* gnu/packages/syncthing.scm (go-github-com-rcrowley-go-metrics) [arguments]: Skip tests when building on or for aarch64-linux.
Diffstat (limited to 'gnu/packages/syncthing.scm')
-rw-r--r--gnu/packages/syncthing.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 99bdd7704b..dfc222057e 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -531,7 +531,11 @@ higher-level API for doing so.")
"1hfxffnpaw49pr3wrkbzq3pnv3nyzsvk5dxndv0yz70xlrbg8a04"))))
(build-system go-build-system)
(arguments
- `(#:import-path "github.com/rcrowley/go-metrics"))
+ ;; Arbitrary precision tests are known to be broken on aarch64, ppc64le
+ ;; and s390x. See: https://github.com/rcrowley/go-metrics/issues/249
+ `(#:tests? ,(not (string-prefix? "aarch64" (or (%current-target-system)
+ (%current-system))))
+ #:import-path "github.com/rcrowley/go-metrics"))
(propagated-inputs
`(("go-github-com-stathat-go" ,go-github-com-stathat-go)))
(synopsis "Go port of Coda Hale's Metrics library")