summaryrefslogtreecommitdiff
path: root/gnu/packages/syncthing.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-12-31 10:25:51 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-12-31 10:25:57 +0200
commit5e3196ff04a4738126d2deede0d12da752f5d591 (patch)
tree5e0f31ca936cae4dd887df7583d71bec09133441 /gnu/packages/syncthing.scm
parent5178cf07841983e472839ee2101fb7d966deba91 (diff)
downloadguix-patches-5e3196ff04a4738126d2deede0d12da752f5d591.tar
guix-patches-5e3196ff04a4738126d2deede0d12da752f5d591.tar.gz
gnu: go-github-com-go-ldap-ldap: Update to 3.4.1.
* gnu/packages/syncthing.scm (go-github-com-go-ldap-ldap): Update to 3.4.1. [propagated-inputs]: Add go-github-com-azure-go-ntlmssp.
Diffstat (limited to 'gnu/packages/syncthing.scm')
-rw-r--r--gnu/packages/syncthing.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 9dfc1d21fc..7125e70117 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -989,7 +989,7 @@ Go language.")
(define-public go-github-com-go-ldap-ldap
(package
(name "go-github-com-go-ldap-ldap")
- (version "3.1.7")
+ (version "3.4.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -997,14 +997,14 @@ Go language.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32
- "1z6wxia7a1jkmasa9mm6g4n8f0qqbp5rw6vk0zyh4vzk7azklnj2"))))
+ (base32 "1xf2jrwhgr06jy4liba48hrz4b7j27r7m9dnl7fj95vazsx2n5br"))))
(build-system go-build-system)
(arguments
'(#:import-path "github.com/go-ldap/ldap/v3"
#:tests? #f)) ; test suite requires internet access
(propagated-inputs
- (list go-github-com-go-asn1-ber-asn1-ber))
+ (list go-github-com-go-asn1-ber-asn1-ber
+ go-github-com-azure-go-ntlmssp))
(home-page "https://github.com/go-ldap/ldap")
(synopsis "LDAP v3 functionality for Go")
(description "This package provides basic LDAP v3 functionality in the Go