summaryrefslogtreecommitdiff
path: root/gnu/packages/syncthing.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2021-12-06 12:08:55 -0500
committerLeo Famulari <leo@famulari.name>2021-12-06 12:10:12 -0500
commit4e282bc934488b1c9ab9e97c838efe058da9e0bd (patch)
tree5acaa97ab0f737a49e283c051b330eca05566d3b /gnu/packages/syncthing.scm
parent30c776a6a836413d85ceaf60e6d5f88a8b8778c3 (diff)
downloadguix-patches-4e282bc934488b1c9ab9e97c838efe058da9e0bd.tar
guix-patches-4e282bc934488b1c9ab9e97c838efe058da9e0bd.tar.gz
gnu: Syncthing: Update to 1.18.4.
* gnu/packages/syncthing.scm (syncthing): Update to 1.18.4. [arguments]: Build with Go 1.17.
Diffstat (limited to 'gnu/packages/syncthing.scm')
-rw-r--r--gnu/packages/syncthing.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index aa718e5e2d..8ae3c3d840 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -45,7 +45,7 @@
(define-public syncthing
(package
(name "syncthing")
- (version "1.16.1")
+ (version "1.18.4")
; XXX After the go-build-system can use "Go modules", stop using bundled
; dependencies for Syncthing.
(source (origin
@@ -55,7 +55,7 @@
"/syncthing-source-v" version ".tar.gz"))
(sha256
(base32
- "0m5k37sp3px8acs3y9an5wzy1wbcbdvqq74jy0pwzfk4bjbr999j"))))
+ "00kw1j2qi5ylbycv43n5177r3a3651qxhds927x6cz0a2b7qac8n"))))
(build-system go-build-system)
;; The primary Syncthing executable goes to "out", while the auxiliary
;; server programs and utility tools go to "utils". This reduces the size
@@ -65,6 +65,7 @@
`(#:modules ((srfi srfi-26) ; for cut
(guix build utils)
(guix build go-build-system))
+ #:go ,go-1.17
#:import-path "github.com/syncthing/syncthing"
;; We don't need to install the source code for end-user applications.
#:install-source? #f