summaryrefslogtreecommitdiff
path: root/gnu/packages/syncthing.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2018-09-29 17:19:58 -0400
committerLeo Famulari <leo@famulari.name>2018-10-02 15:40:52 -0400
commit4cb2112d8f4aac799c756241bf27aaa99ff5a714 (patch)
treea0adc871ba6b99db6a5fd8a97c10a5c6461f6438 /gnu/packages/syncthing.scm
parent712d01bbe9de285bb3007511c94957b13b74118e (diff)
downloadguix-patches-4cb2112d8f4aac799c756241bf27aaa99ff5a714.tar
guix-patches-4cb2112d8f4aac799c756241bf27aaa99ff5a714.tar.gz
gnu: Add gopkg.in/ldap.v2.
* gnu/packages/syncthing.scm (go-gopkg.in-ldap.v2): New variable.
Diffstat (limited to 'gnu/packages/syncthing.scm')
-rw-r--r--gnu/packages/syncthing.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 61b45e111f..cfcfb74aae 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -1388,3 +1388,28 @@ Prometheus HTTP API.")
Go language.")
(home-page "https://gopkg.in/asn1-ber.v1")
(license expat)))
+
+(define-public go-gopkg.in-ldap.v2
+ (package
+ (name "go-gopkg.in-ldap.v2")
+ (version "2.5.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gopkg.in/ldap.v2")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1wf81wy04nhkqs0dg5zkivr4sh37r83bxrfwjz9vr4jq6vmljr3h"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "gopkg.in/ldap.v2"
+ #:tests? #f)) ; the test suite requires network access
+ (propagated-inputs
+ `(("go-gopkg.in-asn1-ber.v1" ,go-gopkg.in-asn1-ber.v1)))
+ (synopsis "LDAP v3 functionality for Go")
+ (description "This package provides basic LDAP v3 functionality in the Go
+language.")
+ (home-page "https://gopkg.in/ldap.v2")
+ (license expat)))