summaryrefslogtreecommitdiff
path: root/gnu/packages/syncthing.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-02-12 21:41:24 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-12 23:33:23 +0000
commit3da105865c53c80c2ed7ac6e54dfb320d1ef06d9 (patch)
tree3e99c145ee755ee81fb1513d21dcd32a1c232155 /gnu/packages/syncthing.scm
parentae60a953d61d6bd28adfa2f73fdbd37202039091 (diff)
downloadguix-patches-3da105865c53c80c2ed7ac6e54dfb320d1ef06d9.tar
guix-patches-3da105865c53c80c2ed7ac6e54dfb320d1ef06d9.tar.gz
gnu: go-github-com-rcrowley-go-metrics: Move to golang-xyz.
* gnu/packages/syncthing.scm (go-github-com-rcrowley-go-metrics): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. Change-Id: Id153e4b8295c1430077941c5e4ee854ef28a56fa
Diffstat (limited to 'gnu/packages/syncthing.scm')
-rw-r--r--gnu/packages/syncthing.scm30
1 files changed, 0 insertions, 30 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index c5f590fb59..9d12a81df8 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -542,36 +542,6 @@ higher-level API for doing so.")
(home-page "https://github.com/stathat/go")
(license expat))))
-(define-public go-github-com-rcrowley-go-metrics
- (let ((commit "cac0b30c2563378d434b5af411844adff8e32960")
- (revision "2"))
- (package
- (name "go-github-com-rcrowley-go-metrics")
- (version (git-version "0.0.0" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/rcrowley/go-metrics")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1hfxffnpaw49pr3wrkbzq3pnv3nyzsvk5dxndv0yz70xlrbg8a04"))))
- (build-system go-build-system)
- (arguments
- ;; Arbitrary precision tests are known to be broken on aarch64, ppc64le
- ;; and s390x. See: https://github.com/rcrowley/go-metrics/issues/249
- `(#:tests? ,(not (string-prefix? "aarch64" (or (%current-target-system)
- (%current-system))))
- #:import-path "github.com/rcrowley/go-metrics"))
- (propagated-inputs
- (list go-github-com-stathat-go))
- (synopsis "Go port of Coda Hale's Metrics library")
- (description "This package provides a Go implementation of Coda Hale's
-Metrics library.")
- (home-page "https://github.com/rcrowley/go-metrics")
- (license bsd-2))))
-
(define-public go-github-com-sasha-s-go-deadlock
(package
(name "go-github-com-sasha-s-go-deadlock")