summaryrefslogtreecommitdiff
path: root/gnu/packages/sync.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-11-21 22:23:13 +0200
committerEfraim Flashner <efraim@flashner.co.il>2016-12-04 08:39:48 +0200
commitcf3504c69c8d58ad5db6ed17083e7bee1e9acd0b (patch)
treeb5706ca9cc725b534bb0bc482be392e957882cbf /gnu/packages/sync.scm
parent760d6066f7089dd900ce079196523f717c0c8b19 (diff)
downloadguix-patches-cf3504c69c8d58ad5db6ed17083e7bee1e9acd0b.tar
guix-patches-cf3504c69c8d58ad5db6ed17083e7bee1e9acd0b.tar.gz
gnu: Add qsyncthingtray.
* gnu/packages/sync.scm (qsyncthingtray): New variable.
Diffstat (limited to 'gnu/packages/sync.scm')
-rw-r--r--gnu/packages/sync.scm55
1 files changed, 55 insertions, 0 deletions
diff --git a/gnu/packages/sync.scm b/gnu/packages/sync.scm
index 186914d98c..a4fdfd303e 100644
--- a/gnu/packages/sync.scm
+++ b/gnu/packages/sync.scm
@@ -103,3 +103,58 @@ to and a server to synchronize to. You can configure more computers to
synchronize to the same server and any change to the files on one computer will
silently and reliably flow across to every other.")
(license license:gpl2+)))
+
+(define-public qsyncthingtray
+ (package
+ (name "qsyncthingtray")
+ (version "0.5.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/sieren/QSyncthingTray/archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0py3593pv3iz0vds82wzbjy1ykc96qaaji1ldd9dlr50kb1840c3"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:configure-flags '("-DQST_BUILD_WEBKIT=1")
+ #:phases
+ (modify-phases %standard-phases
+ ;; The program is meant to be run from the git repo or source tarball.
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin")))
+ (install-file "QSyncthingTray" bin)
+ (install-file (string-append
+ "../QSyncthingTray-"
+ ,(package-version qsyncthingtray)
+ "/resources/images/Icon1024.png")
+ (string-append
+ out "/share/pixmaps/QSyncthingTray.png"))
+ #t))))
+ #:tests? #f)) ; no test target
+ (inputs
+ `(("qtbase" ,qtbase)
+ ("qtwebkit" ,qtwebkit)))
+ (home-page "https://github.com/sieren/QSyncthingTray")
+ (synopsis "Traybar Application for Syncthing")
+ (description
+ "A traybar application for syncthing.
+@enumerate
+@item Shows number of connections at a glance.
+@item Traffic statistics about incoming, outgoing and total throughput.
+@item Launches Syncthing and Syncthing-iNotifier if specified.
+@item Quickly pause Syncthing with one click.
+@item Last Synced Files - Quickly see the recently synchronised files and open
+their folder.
+@item Quick Access to all shared folders.
+@item Presents Syncthing UI in a separate view instead of using the browser.
+@item Supports authenticated HTTPS connections.
+@item Uses System Notifications about current connection status.
+@item Toggle for monochrome icon.
+@end enumerate\n")
+ (license license:lgpl3+)))