summaryrefslogtreecommitdiff
path: root/gnu/packages/sync.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-02-17 21:39:14 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-02-18 00:47:03 +0100
commit836931a5a7036279310ecc955fbdebca3574ab47 (patch)
tree03127905a2934d0516b9984482f062bf41c7cbcd /gnu/packages/sync.scm
parent217ea1a1be0e451f8229809913ade15bbaef651c (diff)
downloadguix-patches-836931a5a7036279310ecc955fbdebca3574ab47.tar
guix-patches-836931a5a7036279310ecc955fbdebca3574ab47.tar.gz
gnu: lsyncd: Don't use unstable tarball.
* gnu/packages/sync.scm (lsyncd)[source]: Use GIT-FETCH and GIT-FILE-NAME. [arguments]: Adjust ‘install’ phase to new source directory.
Diffstat (limited to 'gnu/packages/sync.scm')
-rw-r--r--gnu/packages/sync.scm17
1 files changed, 7 insertions, 10 deletions
diff --git a/gnu/packages/sync.scm b/gnu/packages/sync.scm
index d8789de2ce..df9f3b0e16 100644
--- a/gnu/packages/sync.scm
+++ b/gnu/packages/sync.scm
@@ -162,13 +162,13 @@ their folder.
(version "2.2.2")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/axkibe/lsyncd/archive/release-"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/axkibe/lsyncd.git")
+ (commit (string-append "release-" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32
- "02g054qv8rnbxywd4f0gnd13lrlns9175d3ciqnyslhs1zs15nqb"))))
+ (base32 "1q2ixp52r96ckghgmxdbms6xrq8dbziimp8gmgzqfq4lk1v1w80y"))))
(build-system cmake-build-system)
(arguments
`(;; The "tests" target is broken and assumes that tests are run in the
@@ -184,10 +184,7 @@ their folder.
(bin (string-append out "/bin"))
(man (string-append out "/share/man/man1")))
(install-file "lsyncd" bin)
- (install-file (string-append "../lsyncd-release-"
- ,version
- "/doc/manpage/lsyncd.1")
- man)
+ (install-file "../source/doc/manpage/lsyncd.1" man)
#t))))))
(native-inputs
`(("lua" ,lua-5.2)))