summaryrefslogtreecommitdiff
path: root/gnu/packages/sync.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-02-14 03:45:50 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-02-14 03:50:18 +0100
commit811b907da7bad99b7d7493623a0d7d61c388451b (patch)
treeae4cf4ad33577746a7430c4792c870ee9b8d09e9 /gnu/packages/sync.scm
parentd100b9bd97f27cf3257b1b14bb0f9b27a966c27e (diff)
downloadguix-patches-811b907da7bad99b7d7493623a0d7d61c388451b.tar
guix-patches-811b907da7bad99b7d7493623a0d7d61c388451b.tar.gz
gnu: rclone: Update to 1.46.
* gnu/packages/sync.scm (rclone): Update to 1.46. [arguments]: Remove 'set-home-directory' phase.
Diffstat (limited to 'gnu/packages/sync.scm')
-rw-r--r--gnu/packages/sync.scm14
1 files changed, 4 insertions, 10 deletions
diff --git a/gnu/packages/sync.scm b/gnu/packages/sync.scm
index 421e362cde..d8789de2ce 100644
--- a/gnu/packages/sync.scm
+++ b/gnu/packages/sync.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015, 2016, 2017, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
-;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2018 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;;
@@ -249,7 +249,7 @@ over the Internet in an HTTP and CDN friendly way;
(define-public rclone
(package
(name "rclone")
- (version "1.45")
+ (version "1.46")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -258,19 +258,13 @@ over the Internet in an HTTP and CDN friendly way;
(file-name (git-file-name name version))
(sha256
(base32
- "06xg0ibv9pnrnmabh1kblvxx1pk8h5rmkr9mjbymv497sx3zgz26"))))
+ "1fl52dl41n76r678nzkxa2kgk9khn1fxraxgk8jd3ayc787qs9ia"))))
;; FIXME: Rclone bundles some libraries Guix already provides. Need to
;; un-bundle them.
(build-system go-build-system)
(arguments
'(#:import-path "github.com/ncw/rclone"
- #:install-source? #f
- #:phases
- (modify-phases %standard-phases
- ;; Fix failure during "check" phase: "mkdir /homeless-shelter:
- ;; permission denied".
- (add-after 'unpack 'set-home-directory
- (lambda _ (setenv "HOME" "/tmp") #t)))))
+ #:install-source? #f))
(synopsis "@code{rsync} for cloud storage")
(description "@code{Rclone} is a command line program to sync files and
directories to and from different cloud storage providers.