summaryrefslogtreecommitdiff
path: root/gnu/packages/sync.scm
diff options
context:
space:
mode:
authorDaniel Meißner <daniel.meissner-i4k@ruhr-uni-bochum.de>2021-06-16 14:16:10 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2021-10-11 15:22:12 +0200
commit011db530aa329ac9160441322a6d55e27fe77df2 (patch)
tree438bee52497f210f715a0baa9d6b30e56d6aa307 /gnu/packages/sync.scm
parent94bbc4e410dc96b188ffefe620312a0cd35fe4fb (diff)
downloadguix-patches-011db530aa329ac9160441322a6d55e27fe77df2.tar
guix-patches-011db530aa329ac9160441322a6d55e27fe77df2.tar.gz
gnu: owncloud-client: Fix sysconfdir path
Somehow sysconfdir was not set correctly so that owncloud searched for sync-exclude.lst in the relative path etc/ownCloud/sync-exclude.lst instead of the /gnu/store/...-owncloud-client/etc/ownCloud/sync-exclude.lst. * gnu/packages/sync.scm(owncloud-client): Add -DSYSCONF_INSTALL_DIR flag to configure flags. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu/packages/sync.scm')
-rw-r--r--gnu/packages/sync.scm10
1 files changed, 8 insertions, 2 deletions
diff --git a/gnu/packages/sync.scm b/gnu/packages/sync.scm
index c1c1e7d57c..e9fc913ad5 100644
--- a/gnu/packages/sync.scm
+++ b/gnu/packages/sync.scm
@@ -341,10 +341,16 @@ See also: megacmd, the official tool set by MEGA.")
(("QCoreApplication::applicationFilePath\\()") "\"owncloud\""))
#t))
(delete 'patch-dot-desktop-files))
- #:configure-flags '("-DUNIT_TESTING=ON"
+ #:configure-flags `("-DUNIT_TESTING=ON"
;; build without qtwebkit, which causes the
;; package to FTBFS while looking for QWebView.
- "-DNO_SHIBBOLETH=1")))
+ "-DNO_SHIBBOLETH=1"
+ ;; Fix sync-exclude.list problem, see
+ ;; <https://github.com/owncloud/client/issues/8373>
+ ;; <https://issues.guix.gnu.org/47672>
+ ,(string-append "-DSYSCONF_INSTALL_DIR="
+ (assoc-ref %outputs "out")
+ "/etc"))))
(native-inputs
`(("cmocka" ,cmocka)
("extra-cmake-modules" ,extra-cmake-modules)