summaryrefslogtreecommitdiff
path: root/gnu/packages/swig.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 17:18:24 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 17:48:25 +0100
commit8394619baceb118df92e355377fd543bb1aa501a (patch)
tree504f07c2a9f88596a305b59ef45f941062426a52 /gnu/packages/swig.scm
parentaca2defe0172868295941fd9f0e97886f6e9b2d4 (diff)
downloadguix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar
guix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar.gz
gnu: Simplify package inputs.
This commit was obtained by running: ./pre-inst-env guix style without any additional argument.
Diffstat (limited to 'gnu/packages/swig.scm')
-rw-r--r--gnu/packages/swig.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/swig.scm b/gnu/packages/swig.scm
index b14bcd6401..1f4bd0922a 100644
--- a/gnu/packages/swig.scm
+++ b/gnu/packages/swig.scm
@@ -45,13 +45,13 @@
(base32
"1z06m5zv87mha6hvys1iay810ghc1jngilfby1ms2n4d1mryjfym"))))
(build-system gnu-build-system)
- (native-inputs `(("boost" ,boost)
- ("pcre" ,pcre "bin") ;for 'pcre-config'
- ;; The following are for tests and examples:
- ("guile" ,guile-3.0)
- ("perl" ,perl)))
+ (native-inputs (list boost
+ `(,pcre "bin") ;for 'pcre-config'
+ ;; The following are for tests and examples:
+ guile-3.0
+ perl))
;;("python" ,python-wrapper)
- (inputs `(("pcre" ,pcre)))
+ (inputs (list pcre))
(home-page "http://swig.org/")
(synopsis
"Interface compiler that connects C/C++ code to higher-level languages")