summaryrefslogtreecommitdiff
path: root/gnu/packages/swig.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-12-01 10:31:28 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-12-01 10:31:28 +0200
commit7ed91f8c8de0de7df992c1534a1c86219ab5ba84 (patch)
tree131cc0fe3fdb1523ce474c1eca8b04d98021039d /gnu/packages/swig.scm
parentb7fd304e28a3206e565d568c3f988a72b57d0b16 (diff)
downloadguix-patches-7ed91f8c8de0de7df992c1534a1c86219ab5ba84.tar
guix-patches-7ed91f8c8de0de7df992c1534a1c86219ab5ba84.tar.gz
gnu: swig: Clean up inputs.
* gnu/packages/swig.scm (swig)[inputs]: Move perl, guile-2.0 ... [inputs]: ... to here.
Diffstat (limited to 'gnu/packages/swig.scm')
-rw-r--r--gnu/packages/swig.scm19
1 files changed, 7 insertions, 12 deletions
diff --git a/gnu/packages/swig.scm b/gnu/packages/swig.scm
index 90d698a8b4..e10e30b332 100644
--- a/gnu/packages/swig.scm
+++ b/gnu/packages/swig.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2013, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2018 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -60,18 +61,12 @@
(("-isystem ") "-I"))
#t)))))
(native-inputs `(("boost" ,boost)
- ("pcre" ,pcre "bin"))) ;for 'pcre-config'
- (inputs `(;; Provide these to run the corresponding tests.
- ("pcre" ,pcre)
- ("guile" ,guile-2.0)
- ("perl" ,perl)))
- ;; FIXME: reactivate input python as soon as the test failures
- ;; fatal error: Python.h: No such file or directory
- ;; # include <Python.h>
- ;; are fixed.
- ;; The python part probably never worked and does not seem to
- ;; be needed for currently dependent packages.
-;; ("python" ,python-wrapper)))
+ ("pcre" ,pcre "bin") ;for 'pcre-config'
+ ;; The following are for tests and examples:
+ ("guile" ,guile-2.0)
+ ("perl" ,perl)))
+ ;;("python" ,python-wrapper)
+ (inputs `(("pcre" ,pcre)))
(home-page "http://swig.org/")
(synopsis
"Interface compiler that connects C/C++ code to higher-level languages")