summaryrefslogtreecommitdiff
path: root/gnu/packages/swig.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-01-06 11:02:25 +0000
committerMark H Weaver <mhw@netris.org>2015-01-06 13:40:50 -0500
commit77a39799f9c9f416ba86b80099db2b4040624115 (patch)
treeb46053d2b70e049de7b1469da921bba46eeeabf8 /gnu/packages/swig.scm
parent0d93648bece32ba516812b3a4264dd0a72810dbf (diff)
downloadguix-patches-77a39799f9c9f416ba86b80099db2b4040624115.tar
guix-patches-77a39799f9c9f416ba86b80099db2b4040624115.tar.gz
gnu: swig: Build a UTF-8 locale for the tests.
* gnu/packages/swig.scm (swig)[arguments]: Add 'install-locales' phase.
Diffstat (limited to 'gnu/packages/swig.scm')
-rw-r--r--gnu/packages/swig.scm13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/swig.scm b/gnu/packages/swig.scm
index ce91df5eda..a978dec681 100644
--- a/gnu/packages/swig.scm
+++ b/gnu/packages/swig.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -53,6 +54,18 @@
;; The python part probably never worked and does not seem to
;; be needed for currently dependent packages.
;; ("python" ,python-wrapper)))
+ (arguments
+ `(#:phases
+ (alist-cons-before
+ 'check 'install-locales
+ (lambda _
+ ;; One of the tests requires the availability of a UTF-8
+ ;; locale and otherwise fails.
+ (setenv "LOCPATH" (getcwd))
+ (zero? (system* "localedef" "--no-archive"
+ "--prefix" (getcwd) "-i" "en_US"
+ "-f" "UTF-8" "./en_US.utf8")))
+ %standard-phases)))
(home-page "http://swig.org/")
(synopsis
"Interface compiler that connects C/C++ code to higher-level languages")