summaryrefslogtreecommitdiff
path: root/gnu/packages/swig.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-02-27 14:49:27 +0100
committerLudovic Courtès <ludo@gnu.org>2015-02-27 15:08:37 +0100
commit7184b4b1bd839cd4fd0c9630c050c7854174057d (patch)
tree4d0a639e98498bda398557ab53a674caaf332902 /gnu/packages/swig.scm
parentda6dd842d038aa0761918305953ad92951fb663f (diff)
downloadguix-patches-7184b4b1bd839cd4fd0c9630c050c7854174057d.tar
guix-patches-7184b4b1bd839cd4fd0c9630c050c7854174057d.tar.gz
gnu: Remove now unneeded 'localedef' invocations.
This is a followup to commit b0fd2bd. * gnu/packages/gawk.scm (gawk)[arguments] <install-locales>: Add comment on why we leave this here. * gnu/packages/guile.scm (guile-ncurses)[arguments]: Remove 'install-locales' phase. * gnu/packages/swig.scm (swig)[arguments]: Likewise. * gnu/packages/python.scm (python-matplotlib): Remove 'LOCPATH' setting and 'localedef' invocation. (python-scipy): Likewise.
Diffstat (limited to 'gnu/packages/swig.scm')
-rw-r--r--gnu/packages/swig.scm14
1 files changed, 1 insertions, 13 deletions
diff --git a/gnu/packages/swig.scm b/gnu/packages/swig.scm
index a978dec681..bd7978da50 100644
--- a/gnu/packages/swig.scm
+++ b/gnu/packages/swig.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
;;;
;;; This file is part of GNU Guix.
@@ -54,18 +54,6 @@
;; The python part probably never worked and does not seem to
;; be needed for currently dependent packages.
;; ("python" ,python-wrapper)))
- (arguments
- `(#:phases
- (alist-cons-before
- 'check 'install-locales
- (lambda _
- ;; One of the tests requires the availability of a UTF-8
- ;; locale and otherwise fails.
- (setenv "LOCPATH" (getcwd))
- (zero? (system* "localedef" "--no-archive"
- "--prefix" (getcwd) "-i" "en_US"
- "-f" "UTF-8" "./en_US.utf8")))
- %standard-phases)))
(home-page "http://swig.org/")
(synopsis
"Interface compiler that connects C/C++ code to higher-level languages")