summaryrefslogtreecommitdiff
path: root/gnu/packages/suckless.scm
diff options
context:
space:
mode:
authorng0 <ng0@libertad.pw>2017-01-12 00:39:23 +0000
committerLeo Famulari <leo@famulari.name>2017-01-13 14:13:01 -0500
commitf63abd0d10384522a0da14f0d0ad683a5ff83b33 (patch)
treeea930e04cdfb942fa61264414040fe4d93f072ff /gnu/packages/suckless.scm
parent4f5a0f32f4d826595705332ba54acb4bffee3c07 (diff)
downloadguix-patches-f63abd0d10384522a0da14f0d0ad683a5ff83b33.tar
guix-patches-f63abd0d10384522a0da14f0d0ad683a5ff83b33.tar.gz
gnu: Add wificurse.
* gnu/packages/suckless.scm (wificurse): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/suckless.scm')
-rw-r--r--gnu/packages/suckless.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/suckless.scm b/gnu/packages/suckless.scm
index 1d35e93893..bcfa16922b 100644
--- a/gnu/packages/suckless.scm
+++ b/gnu/packages/suckless.scm
@@ -282,3 +282,36 @@ few minutes.")
(description
"Xbattmon is a simple battery monitor for X.")
(license license:isc)))
+
+(define-public wificurse
+ (package
+ (name "wificurse")
+ (version "0.3.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://dl.2f30.org/releases/"
+ name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "067ghr1xly5ca41kc83xila1p5hpq0bxfcmc8jvxi2ggm6wrhavn"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; No tests
+ #:make-flags (list
+ (string-append "PREFIX=" %output))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)))) ; No configure script
+ (home-page "http://git.2f30.org/wificurse/")
+ (synopsis "Wifi DoS attack tool")
+ (description
+ "Wificurses listens for beacons sent from wireless access points
+in the range of your wireless station. Once received the program
+extracts the BSSID of the AP and transmits deauthentication packets
+using the broadcast MAC address. This results to the disconnection
+of all clients connected to the AP at the time of the attack. This
+is essencially a WiFi DoS attack tool created for educational
+purposes only. It works only in Linux and requires wireless card
+drivers capable of injecting packets in wireless networks.")
+ (license license:gpl3+)))