summaryrefslogtreecommitdiff
path: root/gnu/packages/suckless.scm
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2021-11-06 04:52:47 -0400
committerMathieu Othacehe <othacehe@gnu.org>2021-12-26 19:22:35 +0100
commitea780316b0d8063d58994ca37bb503204b0f3af5 (patch)
tree66f4a9a2b94063179f5d9f55791fd7737c7e6e39 /gnu/packages/suckless.scm
parent3fbe61fa50b7cab4cbbb8551f7ab9dc4735a0eb7 (diff)
downloadguix-patches-ea780316b0d8063d58994ca37bb503204b0f3af5.tar
guix-patches-ea780316b0d8063d58994ca37bb503204b0f3af5.tar.gz
gnu: Add xst.
* gnu/packages/suckless.scm (xst): New variable. Co-authored-by: Raghav Gururajan <rg@raghavgururajan.name> Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/suckless.scm')
-rw-r--r--gnu/packages/suckless.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/suckless.scm b/gnu/packages/suckless.scm
index 04803c8fd3..7fb879a7ad 100644
--- a/gnu/packages/suckless.scm
+++ b/gnu/packages/suckless.scm
@@ -393,6 +393,37 @@ antialiased fonts (using fontconfig), fallback fonts, resizing, and line
drawing.")
(license license:x11)))
+(define-public xst
+ (package
+ (inherit st)
+ (name "xst")
+ (version "0.8.4.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gnotclub/xst")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1q64x7czpbcg0v509qchn5v96zdnx7jmvy0zxhjmkk3d10x5rqlw"))))
+ (home-page "https://github.com/gnotclub/xst")
+ (synopsis "Fork of st that uses Xresources")
+ (description
+ "@command{xst} uses Xresources and applies the following patches to
+@command{st}:
+@itemize
+@item @uref{https://st.suckless.org/patches/alpha/, alpha}
+@item @uref{https://st.suckless.org/patches/boxdraw/, boxdraw}
+@item @uref{https://st.suckless.org/patches/clipboard/, clipboard}
+@item @uref{https://st.suckless.org/patches/disable_bold_italic_fonts/, disable_bold_italic_fonts}
+@item @uref{https://st.suckless.org/patches/externalpipe/, externalpipe}
+@item @uref{https://st.suckless.org/patches/scrollback/, scrollback}
+@item @uref{https://st.suckless.org/patches/spoiler/, spoiler}
+@item @uref{https://st.suckless.org/patches/vertcenter/, vertcenter}
+@end itemize")
+ (license license:expat)))
+
(define-public surf
(package
(name "surf")