summaryrefslogtreecommitdiff
path: root/gnu/packages/suckless.scm
diff options
context:
space:
mode:
authorng0 <ng0@libertad.pw>2017-01-12 00:39:30 +0000
committerLeo Famulari <leo@famulari.name>2017-01-13 14:13:03 -0500
commit73aca00d53a5d810496b1f9910d98a45d3255dfe (patch)
treec9696f51d6ac8eef2628da3ff25b31dd2c103765 /gnu/packages/suckless.scm
parent823d7f536be5511a1bab8b52b29fd8f35a3fae78 (diff)
downloadguix-patches-73aca00d53a5d810496b1f9910d98a45d3255dfe.tar
guix-patches-73aca00d53a5d810496b1f9910d98a45d3255dfe.tar.gz
gnu: Add human.
* gnu/packages/suckless.scm (human): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/suckless.scm')
-rw-r--r--gnu/packages/suckless.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/suckless.scm b/gnu/packages/suckless.scm
index b52a43f1f2..2f22f300d2 100644
--- a/gnu/packages/suckless.scm
+++ b/gnu/packages/suckless.scm
@@ -27,6 +27,7 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix download)
+ #:use-module (guix git-download)
#:use-module (guix build-system gnu)
#:use-module (guix build-system glib-or-gtk)
#:use-module (gnu packages)
@@ -467,3 +468,38 @@ cups server to be installed.")
(description
"Noice is a small curses-based file browser.")
(license license:bsd-2)))
+
+;;; We want some commits that are more recent than the latest release, 0.2
+(define-public human
+ (let ((commit "50c80e6ba12823184b6866e06b955dbd2ccdc5d7")
+ (revision "1"))
+ (package
+ (name "human")
+ (version (string-append "0.2-" revision "." (string-take commit 7)))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "git://git.2f30.org/human.git")
+ (commit commit)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "18xngm4h9vsyip52zwd79rrp1irzg6rs462lpbp61amf7hj955gn"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; No tests
+ #:make-flags (list "CC=gcc"
+ (string-append "PREFIX=" %output))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)))) ; No configure script
+ (home-page "http://git.2f30.org/human/")
+ (synopsis "Convert bytes to human readable formats")
+ (description
+ "Human is a small program which translate numbers into a
+human readable format. By default, it tries to detect the best
+factorisation, but you can force its output.
+You can adjust the number of decimals with the @code{SCALE}
+environment variable.")
+ (license license:wtfpl2))))