summaryrefslogtreecommitdiff
path: root/gnu/packages/suckless.scm
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2021-10-22 00:12:22 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-10-22 00:12:22 +0200
commit48c40581356e5eb84fefb66c6f47ff97f17c48ca (patch)
treefe5ae6f95dae30a4b9d4a35b3f74cda1b0d53a12 /gnu/packages/suckless.scm
parent886d04425e5a087816979b8a96b1e706693b5f93 (diff)
downloadguix-patches-48c40581356e5eb84fefb66c6f47ff97f17c48ca.tar
guix-patches-48c40581356e5eb84fefb66c6f47ff97f17c48ca.tar.gz
gnu: Add snooze.
* gnu/packages/suckless.scm (snooze): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/suckless.scm')
-rw-r--r--gnu/packages/suckless.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/suckless.scm b/gnu/packages/suckless.scm
index 59cf542455..e80ed2bca0 100644
--- a/gnu/packages/suckless.scm
+++ b/gnu/packages/suckless.scm
@@ -904,6 +904,39 @@ It is a front end for ii-like chat programs. It uses @code{tail -f} to get the
chat output in the background.")
(license license:isc))))
+(define-public snooze
+ (package
+ (name "snooze")
+ (version "0.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/leahneukirchen/snooze")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "02ng3r1gzgpyjia4b60i11dj5bhn3xjsdcbwmxaam6dzb33dmgib"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; There are no tests.
+ #:make-flags
+ (list (string-append "CC=" ,(cc-for-target))
+ (string-append "DESTDIR=" %output)
+ ;; Set prefix path to root of package path in store instead
+ ;; of /usr/local.
+ (string-append "PREFIX=" %output))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (home-page "https://github.com/leahneukirchen/snooze")
+ (synopsis "Run a command at a particular time")
+ (description
+"@command{snooze} is a tool for waiting until a particular time and then
+running a command.")
+ (license license:cc0)))
+
(define-public scron
(package
(name "scron")