summaryrefslogtreecommitdiff
path: root/gnu/packages/storage.scm
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2021-10-05 17:55:04 +0000
committerMarius Bakke <marius@gnu.org>2021-10-08 00:00:21 +0200
commit04c5d89482caa152881a453085e201e7b9b6576e (patch)
tree63edfca030c9900568c32a3b87e047a44df92891 /gnu/packages/storage.scm
parentf86f7e24b39928247729020df0134e2e1c4cde62 (diff)
downloadguix-patches-04c5d89482caa152881a453085e201e7b9b6576e.tar
guix-patches-04c5d89482caa152881a453085e201e7b9b6576e.tar.gz
gnu: ceph: Fix breaking change in snappy.
* gnu/packages/storage.scm (ceph)[source]: Add patch. * gnu/packages/patches/ceph-fix-snappy-breaking-change.patch: New file. * gnu/local.mk: Add it. Signed-off-by: Marius Bakke <marius@gnu.org>
Diffstat (limited to 'gnu/packages/storage.scm')
-rw-r--r--gnu/packages/storage.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/storage.scm b/gnu/packages/storage.scm
index d53327df75..4dfae1e80e 100644
--- a/gnu/packages/storage.scm
+++ b/gnu/packages/storage.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2017, 2018, 2019, 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2021 Greg Hogan <code@greghogan.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -64,7 +65,9 @@
(base32
"0lmdri415hqczc9565s5m5568pnj97ipqxgnw6085kps0flwq5zh"))
(patches
- (search-patches "ceph-disable-cpu-optimizations.patch"))
+ (search-patches
+ "ceph-disable-cpu-optimizations.patch"
+ "ceph-fix-snappy-breaking-change.patch"))
(modules '((guix build utils)))
(snippet
'(begin