summaryrefslogtreecommitdiff
path: root/gnu/packages/statistics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-02-15 17:05:08 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-02-15 17:05:08 +0100
commitca372a49452c2ab340c350f5854d0fec049dc9f7 (patch)
tree123e258a3de4cba21cc16f72d5c8a91c7a37bd44 /gnu/packages/statistics.scm
parent9904a15a4c838362673c1affdbaf1e83d92fe8ff (diff)
downloadguix-patches-ca372a49452c2ab340c350f5854d0fec049dc9f7.tar
guix-patches-ca372a49452c2ab340c350f5854d0fec049dc9f7.tar.gz
gnu: r-with-tests: Update to 4.0.4.
* gnu/packages/statistics.scm (r-with-tests): Update to 4.0.4. [arguments]: Update phase "build-reproducibly".
Diffstat (limited to 'gnu/packages/statistics.scm')
-rw-r--r--gnu/packages/statistics.scm13
1 files changed, 6 insertions, 7 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 7a5f319ed7..3821c86da9 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -184,7 +184,7 @@ This package also provides @command{xls2csv} to export Excel files to CSV.")
(define r-with-tests
(package
(name "r-with-tests")
- (version "4.0.3")
+ (version "4.0.4")
(source (origin
(method url-fetch)
(uri (string-append "mirror://cran/src/base/R-"
@@ -192,7 +192,7 @@ This package also provides @command{xls2csv} to export Excel files to CSV.")
version ".tar.gz"))
(sha256
(base32
- "03cypg2qf7v9mq9mr9alz9w5y9m5kdgwbc97bp26pyymg253m609"))))
+ "0bl098xcv8v316kqnf43v6gb4kcsv31ydqfm1f7qr824jzb2fgsj"))))
(build-system gnu-build-system)
(arguments
`(#:disallowed-references (,tzdata-for-tests)
@@ -272,12 +272,11 @@ as.POSIXct(if (\"\" != Sys.getenv(\"SOURCE_DATE_EPOCH\")) {\
;; The "References" section of this file when converted to
;; package.rds is sometimes stored with a newline, sometimes with
- ;; a space. We avoid this problem by adding characters to break
- ;; up the series of line break and spaces that is suspected to be
- ;; the culprit.
+ ;; a space. We avoid this problem by removing the line break
+ ;; that is suspected to be the culprit.
(substitute* "src/library/methods/DESCRIPTION.in"
- ((" ``Software")
- " -- ``Software"))
+ (("\\(2008\\)\n") "(2008) ")
+ ((" ``Software") "``Software"))
#t))
(add-before 'build 'set-locales
(lambda _