summaryrefslogtreecommitdiff
path: root/gnu/packages/statistics.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-01-03 19:41:05 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-03 19:41:05 +0100
commit982eff9e841f3539e4ecf93669435a290bfde571 (patch)
treeb1e3f6fc85c6c35c264f091eb2fc5cff8514c230 /gnu/packages/statistics.scm
parent7ba6d70e4528201151195e1ed2175ee4828bdb2f (diff)
parent7158fe4ded47a599ceb8d556132ba83fcc686962 (diff)
downloadguix-patches-982eff9e841f3539e4ecf93669435a290bfde571.tar
guix-patches-982eff9e841f3539e4ecf93669435a290bfde571.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/statistics.scm')
-rw-r--r--gnu/packages/statistics.scm54
1 files changed, 28 insertions, 26 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 9222bba0f6..536de0fd7b 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -8,7 +8,7 @@
;;; Copyright © 2016 Ben Woodcroft <donttrustben@gmail.com>
;;; Copyright © 2016, 2017 Raoul Bonnal <ilpuccio.febo@gmail.com>
;;; Copyright © 2017 Kyle Meyer <kyle@kyleam.com>
-;;; Copyright © 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Alex Kost <alezost@gmail.com>
;;; Copyright © 2018 Alex Branham <alex.branham@gmail.com>
;;;
@@ -159,14 +159,14 @@ simulation not wholly unlike BUGS. JAGS was written with three aims in mind:
(define-public libxls
(package
(name "libxls")
- (version "1.5.1")
+ (version "1.5.2")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/libxls/libxls/releases/download/"
"v" version "/libxls-" version ".tar.gz"))
(sha256
- (base32 "0dam8qgbc5ykzaxmrjhpmfm8lnlcdk6cbpzyaya91qwwa80qbj1v"))))
+ (base32 "1akadsyl10rp101ccjmrxr7933c3v641k377bn74jv6cdkcm4zld"))))
(build-system gnu-build-system)
(home-page "https://github.com/libxls/libxls")
(synopsis "Read binary (.xls) Excel spreadsheet files")
@@ -399,14 +399,14 @@ available, greatly increasing its breadth and scope.")
(define-public r-boot
(package
(name "r-boot")
- (version "1.3-23")
+ (version "1.3-24")
(source
(origin
(method url-fetch)
(uri (cran-uri "boot" version))
(sha256
(base32
- "0bx07zbb5nfz2xfgnzbspg7r5vxz4bjdz1ry4d1vk434vlcrxj1h"))))
+ "0yv0l55kjmlfdx1xhgyjdi0bskxhfal74wr5jxaib1qj99nmkm49"))))
(build-system r-build-system)
(home-page "https://cran.r-project.org/web/packages/boot")
(synopsis "Bootstrap functions for R")
@@ -420,14 +420,14 @@ D.V. Hinkley (1997, CUP), originally written by Angelo Canty for S.")
(define-public r-mass
(package
(name "r-mass")
- (version "7.3-51.4")
+ (version "7.3-51.5")
(source
(origin
(method url-fetch)
(uri (cran-uri "MASS" version))
(sha256
(base32
- "0x1ckf51y851g0kvbhsgdxb26vfpmbw3xdbcnh3ck7fjm13da4cr"))))
+ "1k0m7pa4gb5apzrrkb5kx5d7bmkm2pl5g15vwb6j067hrqahck26"))))
(properties `((upstream-name . "MASS")))
(build-system r-build-system)
(home-page "http://www.stats.ox.ac.uk/pub/MASS4/")
@@ -504,14 +504,14 @@ code for possible problems.")
(define-public r-foreign
(package
(name "r-foreign")
- (version "0.8-72")
+ (version "0.8-74")
(source
(origin
(method url-fetch)
(uri (cran-uri "foreign" version))
(sha256
(base32
- "124c9229is44p2rv7xyh2q86nsfi7vzyyh5n3c5ihziqrp4ig723"))))
+ "047w772msiki85rxxhqkxya37gmw4331l32651rr09dl2vq02pgj"))))
(build-system r-build-system)
(home-page "https://cran.r-project.org/web/packages/foreign")
(synopsis "Read data stored by other statistics software")
@@ -1260,13 +1260,13 @@ R/DBMS implementations.")
(define-public r-bh
(package
(name "r-bh")
- (version "1.72.0-1")
+ (version "1.72.0-2")
(source (origin
(method url-fetch)
(uri (cran-uri "BH" version))
(sha256
(base32
- "1cm3gawky0dlfj8awv356j3f5pfv732rz10wlfnix2s2xf5cdz4a"))))
+ "0y1cxnzdajcdsc9jlaby53253hril65h496wval08qlxsqnfc3ia"))))
(build-system r-build-system)
(home-page "https://github.com/eddelbuettel/bh")
(synopsis "R package providing subset of Boost headers")
@@ -1337,13 +1337,13 @@ supported via Andre Simon's highlight package.")
(define-public r-mime
(package
(name "r-mime")
- (version "0.7")
+ (version "0.8")
(source (origin
(method url-fetch)
(uri (cran-uri "mime" version))
(sha256
(base32
- "12vpip67ajb90b8p96w43ir7mavrw2i61bwvpfnrlmlj9kj3w20i"))))
+ "18w98prfbivvygiyamsf9yg090kzbnvw2fn9b27823gmis4d08ny"))))
(build-system r-build-system)
(home-page "https://github.com/yihui/mime")
(synopsis "R package to map filenames to MIME types")
@@ -2540,18 +2540,20 @@ scaling functions for R.")
(define-public r-latticeextra
(package
(name "r-latticeextra")
- (version "0.6-28")
+ (version "0.6-29")
(source
(origin
(method url-fetch)
(uri (cran-uri "latticeExtra" version))
(sha256
(base32
- "1hkyqsa7klk5glj9y1hg3rxr5qilqw8h0017zc4c3nps7lr9a1kq"))))
+ "04fzwcqs594rk5qp98yilh3kdh3sw4xf8wld5rp94ggpaqfw7bbc"))))
(properties `((upstream-name . "latticeExtra")))
(build-system r-build-system)
(propagated-inputs
- `(("r-lattice" ,r-lattice)
+ `(("r-jpeg" ,r-jpeg)
+ ("r-lattice" ,r-lattice)
+ ("r-png" ,r-png)
("r-rcolorbrewer" ,r-rcolorbrewer)))
(home-page "http://latticeextra.r-forge.r-project.org/")
(synopsis "Extra graphical utilities based on lattice")
@@ -2777,13 +2779,13 @@ a column in data frame.")
(define-public r-rsqlite
(package
(name "r-rsqlite")
- (version "2.1.4")
+ (version "2.1.5")
(source (origin
(method url-fetch)
(uri (cran-uri "RSQLite" version))
(sha256
(base32
- "1vhaq6zfqilya669l100adcw51xz0p370zabnk2dnk1xhdih1f34"))))
+ "0b1cjnk9g1lrxy0wajfq744qps7fila0xdh5j9chy1vrrwfiwzl0"))))
(properties `((upstream-name . "RSQLite")))
(build-system r-build-system)
(propagated-inputs
@@ -3130,13 +3132,13 @@ using the multicore functionality of the parallel package.")
(define-public r-dt
(package
(name "r-dt")
- (version "0.10")
+ (version "0.11")
(source (origin
(method url-fetch)
(uri (cran-uri "DT" version))
(sha256
(base32
- "0vwhn1mcwv0hkbxnppf6vip23iiib0szvp1h3prawlkvd74xziiw"))))
+ "09k9s07aah1apc308sj1abvr27mky6fkpl9j6lxl2x55n4immvkg"))))
(properties
`((upstream-name . "DT")))
(build-system r-build-system)
@@ -3400,14 +3402,14 @@ message passing.")
(define-public r-bigmemory
(package
(name "r-bigmemory")
- (version "4.5.33")
+ (version "4.5.36")
(source
(origin
(method url-fetch)
(uri (cran-uri "bigmemory" version))
(sha256
(base32
- "0ycl9dzm3drpyas625h34rir5bnbjlncxlvawfsfmqwcbmwdjdvj"))))
+ "03pg8mxdc7q0249visjmc8bc3xmwxsfg3i2n6higicj4cfz7zihq"))))
(build-system r-build-system)
(propagated-inputs
`(("r-bh" ,r-bh)
@@ -4889,14 +4891,14 @@ generally.")
(define-public r-robust
(package
(name "r-robust")
- (version "0.4-18.1")
+ (version "0.4-18.2")
(source
(origin
(method url-fetch)
(uri (cran-uri "robust" version))
(sha256
(base32
- "0xs098pfw5zdcdk3rsxkylfl6d2pyp566s5v92bzhgl7h8c90cfy"))))
+ "02x7d6dgx3skiadvx5m3c44b4bhz37ycpfhc25dhhv50y1db6l3k"))))
(build-system r-build-system)
(propagated-inputs
`(("r-fit-models" ,r-fit-models)
@@ -5236,13 +5238,13 @@ Companion to Applied Regression, Third Edition, Sage.")
(define-public r-car
(package
(name "r-car")
- (version "3.0-5")
+ (version "3.0-6")
(source
(origin
(method url-fetch)
(uri (cran-uri "car" version))
(sha256
- (base32 "0w7fm81pn0wqrwzbjyddnrkpjl8gavg7ijh7rab9f21rkgkzgm3y"))))
+ (base32 "0yv5mwaa0ymrbis9590mx0zcj3w6j4drhs6ab13zhx4zc3x1b7b6"))))
(build-system r-build-system)
(propagated-inputs
`(("r-abind" ,r-abind)