summaryrefslogtreecommitdiff
path: root/gnu/packages/statistics.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2021-05-18 14:09:14 +0200
committerLars-Dominik Braun <lars@6xq.net>2021-05-26 14:05:15 +0200
commit6c7aafbedf656ff7cacf39141c649b82abcd7bf7 (patch)
treee2c5fa12e462c1f3dbdd2b327dd9e39d6b69b86e /gnu/packages/statistics.scm
parentfef452b13fc32f63341def0c1aa2ed2df8f77324 (diff)
downloadguix-patches-6c7aafbedf656ff7cacf39141c649b82abcd7bf7.tar
guix-patches-6c7aafbedf656ff7cacf39141c649b82abcd7bf7.tar.gz
gnu: Add r-kknn.
* gnu/packages/statistics.scm (r-kknn): New variable.
Diffstat (limited to 'gnu/packages/statistics.scm')
-rw-r--r--gnu/packages/statistics.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 00378db458..27df2091ee 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -6134,3 +6134,24 @@ input, the effect size can be returned as standardized mean difference, Cohen's
f, Hedges' g, Pearson's r or Fisher's transformation z, odds ratio or log odds,
or eta squared effect size.")
(license license:gpl3)))
+
+(define-public r-kknn
+ (package
+ (name "r-kknn")
+ (version "1.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "kknn" version))
+ (sha256
+ (base32
+ "1nzkg3dxaiqp87p56wm895qx5xn86hv5hjr73qvl1yiaxiq0x112"))))
+ (properties `((upstream-name . "kknn")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-igraph" ,r-igraph) ("r-matrix" ,r-matrix)))
+ (home-page "https://github.com/KlausVigo/kknn")
+ (synopsis "Weighted k-Nearest Neighbors")
+ (description
+ "Weighted k-Nearest Neighbors for Classification, Regression and Clustering.")
+ (license license:gpl2+)))