summaryrefslogtreecommitdiff
path: root/gnu/packages/statistics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-05-25 07:33:02 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-05-28 23:18:42 +0200
commit43e82253c1a0c5608bb97815778ffc19ad4c85b8 (patch)
treec212a1471b54a3ae53542f0eee2c07313724fd4b /gnu/packages/statistics.scm
parent0542905a2c5cb4f645399e19c2a4924dc757057e (diff)
downloadguix-patches-43e82253c1a0c5608bb97815778ffc19ad4c85b8.tar
guix-patches-43e82253c1a0c5608bb97815778ffc19ad4c85b8.tar.gz
gnu: r-with-tests: Update to 4.2.0.
* gnu/packages/statistics.scm (r-with-tests): Update to 4.2.0. [arguments]: Add phase 'patch-tests; add phase 'set-home.
Diffstat (limited to 'gnu/packages/statistics.scm')
-rw-r--r--gnu/packages/statistics.scm17
1 files changed, 15 insertions, 2 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index aad329400f..67f169661f 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -203,7 +203,7 @@ This package also provides @command{xls2csv} to export Excel files to CSV.")
(define r-with-tests
(package
(name "r-with-tests")
- (version "4.1.3")
+ (version "4.2.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://cran/src/base/R-"
@@ -211,7 +211,7 @@ This package also provides @command{xls2csv} to export Excel files to CSV.")
version ".tar.gz"))
(sha256
(base32
- "1mpy4sar1amx5ai9rqr9s0nw8p65iqfrqbm5n9h402b17hrmpzqm"))))
+ "123l17sv3smh5cz0vrjxjj8jf81bb860kah6iww9bl3skdqvgsiq"))))
(build-system gnu-build-system)
(arguments
`(#:disallowed-references (,tzdata-for-tests)
@@ -237,6 +237,16 @@ This package also provides @command{xls2csv} to export Excel files to CSV.")
(("uname") uname-bin))
(substitute* "src/unix/sys-std.c"
(("rm -Rf ") (string-append rm-bin " -Rf "))))))
+ (add-after 'unpack 'patch-tests
+ (lambda _
+ ;; This is needed because R is run during the check phase and
+ ;; /bin/sh doesn't exist in the build container.
+ (substitute* "src/unix/sys-unix.c"
+ (("\"/bin/sh\"")
+ (string-append "\"" (which "sh") "\"")))
+ ;; This test fails because line numbers are off by two.
+ (substitute* "tests/reg-packages.R"
+ (("8 <= print" m) (string-append "## " m)))))
(add-after 'unpack 'build-reproducibly
(lambda _
;; The documentation contains time stamps to demonstrate
@@ -315,6 +325,9 @@ as.POSIXct(if (\"\" != Sys.getenv(\"SOURCE_DATE_EPOCH\")) {\
(setenv "TZDIR"
(search-input-directory inputs
"share/zoneinfo"))))
+ (add-before 'check 'set-home
+ ;; Some tests require that HOME be set.
+ (lambda _ (setenv "HOME" "/tmp")))
(add-after 'build 'make-info
(lambda _ (invoke "make" "info")))
(add-after 'build 'install-info