summaryrefslogtreecommitdiff
path: root/gnu/packages/statistics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2017-05-31 17:12:08 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-06-09 03:28:40 +0200
commit1dacc269567683cedc439545a8077e523a1ed94e (patch)
treefc9fb218c84812a452dc484ce2aeab51953f6bf1 /gnu/packages/statistics.scm
parentdb0bb6f0afad658eddfa350a8ba8c05e151f6a28 (diff)
downloadguix-patches-1dacc269567683cedc439545a8077e523a1ed94e.tar
guix-patches-1dacc269567683cedc439545a8077e523a1ed94e.tar.gz
gnu: Add r-fdrtool.
* gnu/packages/statistics.scm (r-fdrtool): New variable.
Diffstat (limited to 'gnu/packages/statistics.scm')
-rw-r--r--gnu/packages/statistics.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 625f9f4884..ae44bfb01f 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -5257,3 +5257,31 @@ algebraic manipulation on date-time and time-span objects. The 'lubridate'
package has a consistent and memorable syntax that makes working with dates
easy and fun.")
(license license:gpl2)))
+
+(define-public r-fdrtool
+ (package
+ (name "r-fdrtool")
+ (version "1.2.15")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "fdrtool" version))
+ (sha256
+ (base32
+ "1h46frlk7d9f4qx0bg6p55nrm9wwwz2sv6d1nz7061wdfsm69yb5"))))
+ (build-system r-build-system)
+ (home-page "http://strimmerlab.org/software/fdrtool/")
+ (synopsis "Estimation of false discovery rates and higher criticism")
+ (description
+ "This package provides tools to estimate both tail area-based false
+discovery rates (Fdr) as well as local false discovery rates (fdr) for a
+variety of null models (p-values, z-scores, correlation coefficients,
+t-scores). The proportion of null values and the parameters of the null
+distribution are adaptively estimated from the data. In addition, the package
+contains functions for non-parametric density estimation (Grenander
+estimator), for monotone regression (isotonic regression and antitonic
+regression with weights), for computing the greatest convex minorant (GCM) and
+the least concave majorant (LCM), for the half-normal and correlation
+distributions, and for computing empirical higher criticism (HC) scores and
+the corresponding decision threshold.")
+ (license license:gpl3+)))