summaryrefslogtreecommitdiff
path: root/gnu/packages/sssd.scm
diff options
context:
space:
mode:
authorRemco van 't Veer <remco@remworks.net>2022-01-21 21:47:56 +0100
committerOleg Pykhalov <go.wigust@gmail.com>2022-01-22 11:28:21 +0300
commita7fb50b577760e8409f40c7038a7c9a53ba98db6 (patch)
tree690d9e615ce408e41d546ec497b5d65341adc163 /gnu/packages/sssd.scm
parentbef0266be939b276909ee3fe755ef79325763af6 (diff)
downloadguix-patches-a7fb50b577760e8409f40c7038a7c9a53ba98db6.tar
guix-patches-a7fb50b577760e8409f40c7038a7c9a53ba98db6.tar.gz
gnu: sssd: Fix build with samba-4.15.3.
* gnu/packages/patches/sssd-fix-samba-4.15.3.patch: New file. * gnu/local.mk (dist_patch_DATA): Add this. * gnu/packages/sssd.scm [source]: Add this. [native-inputs]: Add AUTOCONF. [arguments]: Add add-config-in phase. Signed-off-by: Oleg Pykhalov <go.wigust@gmail.com>
Diffstat (limited to 'gnu/packages/sssd.scm')
-rw-r--r--gnu/packages/sssd.scm22
1 files changed, 18 insertions, 4 deletions
diff --git a/gnu/packages/sssd.scm b/gnu/packages/sssd.scm
index 9d254d4b3c..3d8c69e722 100644
--- a/gnu/packages/sssd.scm
+++ b/gnu/packages/sssd.scm
@@ -3,7 +3,7 @@
;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2021 Timotej Lazar <timotej.lazar@araneo.si>
-;;; Copyright © 2021 Remco van 't Veer <remco@remworks.net>
+;;; Copyright © 2021, 2022 Remco van 't Veer <remco@remworks.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -152,7 +152,8 @@ fundamental object types for C.")
"1h6hwibaf3xa2w6qpzjiiywmfj6zkgbz4r2isf3gd0xm6vq7n6if"))
(patches (search-patches "sssd-fix-samba.patch"
"sssd-system-directories.patch"
- "sssd-collision-with-external-nss-symbol.patch"))))
+ "sssd-collision-with-external-nss-symbol.patch"
+ "sssd-fix-samba-4.15.3.patch"))))
(build-system gnu-build-system)
(arguments
`(#:make-flags
@@ -196,7 +197,19 @@ fundamental object types for C.")
(lambda _
(substitute* "src/tests/responder_socket_access-tests.c"
(("tcase_add_test\\(tc_utils, resp_str_to_array_test\\);") ""))
- #t)))))
+ #t))
+ (add-after 'unpack 'add-config-in
+ (lambda _
+ (let ((config.h (open-file "config.h.in" "a")))
+ (display (string-append "
+/* Missing in commits on original repo, dunno why but won't work without. */
+#define SMB_HAS_NEW_NDR_PULL_STEAL_SWITCH 1
+")
+ config.h)
+ (close config.h))))
+ (add-before 'configure 'autoconf
+ (lambda _
+ (invoke "autoconf"))))))
(inputs
(list augeas
`(,isc-bind "utils")
@@ -225,7 +238,8 @@ fundamental object types for C.")
tdb
tevent))
(native-inputs
- (list check-0.14
+ (list autoconf-2.69
+ check-0.14
docbook-xsl
docbook-xml
libxml2 ; for xmllint