summaryrefslogtreecommitdiff
path: root/gnu/packages/sssd.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-08-14 22:25:30 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-08-14 22:25:30 +0200
commit5c3f1e4306f252c7dc397ac765caa288a57f99f1 (patch)
treeb6345ad51cd8c443702a8f17c8539e43cc75df7c /gnu/packages/sssd.scm
parent2b3a10b6b5f2a48665cf4bfa27525c4caca175d9 (diff)
downloadguix-patches-5c3f1e4306f252c7dc397ac765caa288a57f99f1.tar
guix-patches-5c3f1e4306f252c7dc397ac765caa288a57f99f1.tar.gz
gnu: sssd: Update to 1.16.4.
* gnu/packages/patches/sssd-curl-compat.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/sssd.scm (sssd): Update to 1.16.4. [source](patches): Remove. [arguments]: Enable fixed tests.
Diffstat (limited to 'gnu/packages/sssd.scm')
-rw-r--r--gnu/packages/sssd.scm9
1 files changed, 2 insertions, 7 deletions
diff --git a/gnu/packages/sssd.scm b/gnu/packages/sssd.scm
index 6d6caab0ad..7bb71dce13 100644
--- a/gnu/packages/sssd.scm
+++ b/gnu/packages/sssd.scm
@@ -81,15 +81,14 @@ fundamental object types for C.")
(define-public sssd
(package
(name "sssd")
- (version "1.16.2")
+ (version "1.16.4")
(source (origin
(method url-fetch)
(uri (string-append "http://releases.pagure.org/SSSD/sssd/"
"sssd-" version ".tar.gz"))
- (patches (search-patches "sssd-curl-compat.patch"))
(sha256
(base32
- "032ppk57qs1lnvz7pb7lw9ldwm9i1yagh9fzgqgn6na3bg61ynzy"))))
+ "0ngr7cgimyjc6flqkm7psxagp1m4jlzpqkn28pliifbmdg6i5ckb"))))
(build-system gnu-build-system)
(arguments
`(#:make-flags
@@ -130,10 +129,6 @@ fundamental object types for C.")
(lambda _
(substitute* "src/tests/responder_socket_access-tests.c"
(("tcase_add_test\\(tc_utils, resp_str_to_array_test\\);") ""))
- ;; XXX: These tests fail with recent versions of ldb. See
- ;; <https://pagure.io/SSSD/sssd/issue/3563>.
- (substitute* "Makefile.in"
- (("sysdb-tests\\$\\(EXEEXT\\)") ""))
#t)))))
(inputs
`(("augeas" ,augeas)