summaryrefslogtreecommitdiff
path: root/gnu/packages/ssh.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-05-28 03:29:56 -0400
committerMark H Weaver <mhw@netris.org>2018-05-28 09:06:13 -0400
commitfe365a3d0e4df7445bf16d3bb422a0bc6bb68ceb (patch)
tree3f29a028b99daca13a94bb70e847495865edc888 /gnu/packages/ssh.scm
parent073cc313131ccf44574b29ef8e1c069288a65b17 (diff)
downloadguix-patches-fe365a3d0e4df7445bf16d3bb422a0bc6bb68ceb.tar
guix-patches-fe365a3d0e4df7445bf16d3bb422a0bc6bb68ceb.tar.gz
gnu: libssh2: Fix build on MIPS systems.
* gnu/packages/ssh.scm (libssh2)[arguments]: When building for MIPS, replace the existing bootstrap phase instead of adding a new 'autoreconf' phase (in the wrong place).
Diffstat (limited to 'gnu/packages/ssh.scm')
-rw-r--r--gnu/packages/ssh.scm23
1 files changed, 18 insertions, 5 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index a0f033305e..dd8518002d 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -116,11 +116,24 @@ remote applications.")
;; zlib libraries, so we need to propagate the inputs.
(propagated-inputs `(("libgcrypt" ,libgcrypt)
("zlib" ,zlib)))
- (arguments '(#:configure-flags `("--with-libgcrypt")
- #:phases (modify-phases %standard-phases
- (add-before 'configure 'autoreconf
- (lambda _
- (invoke "autoreconf" "-v"))))))
+ (arguments `(#:configure-flags `("--with-libgcrypt")
+ #:phases
+ ;; FIXME: In the next core-updates cycle, replace the entire
+ ;; following ,(...) form with its first 'modify-phases'
+ ;; subform. The change made here is only strictly needed on
+ ;; MIPS, but should work on any system. For now, we apply it
+ ;; only to MIPS to avoid forcing thousands of rebuilds on
+ ;; other systems.
+ ,(if (string-prefix? "mips" (or (%current-target-system)
+ (%current-system)))
+ '(modify-phases %standard-phases
+ (replace 'bootstrap
+ (lambda _
+ (invoke "autoreconf" "-v"))))
+ '(modify-phases %standard-phases
+ (add-before 'configure 'autoreconf
+ (lambda _
+ (invoke "autoreconf" "-v")))))))
(native-inputs `(("autoconf" ,autoconf)
("automake" ,automake)))
(synopsis "Client-side C library implementing the SSH2 protocol")