summaryrefslogtreecommitdiff
path: root/gnu/packages/ssh.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-02-09 01:46:34 -0500
committerMark H Weaver <mhw@netris.org>2018-02-09 01:46:34 -0500
commitefe2a2833c6d306d0c60127fdfebaff6dc415b4c (patch)
treebf842134e1a149770907e1956d28c3a6b207b3f7 /gnu/packages/ssh.scm
parent53f826cd0f429864d46fc3bf6305c14356d0b2ad (diff)
parent8d0edc8246389c0f2bb1c8e9c9190c312746a4b4 (diff)
downloadguix-patches-efe2a2833c6d306d0c60127fdfebaff6dc415b4c.tar
guix-patches-efe2a2833c6d306d0c60127fdfebaff6dc415b4c.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/ssh.scm')
-rw-r--r--gnu/packages/ssh.scm59
1 files changed, 32 insertions, 27 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 793dcf8dc5..b439094c26 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2013, 2014 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2014, 2015, 2016 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015, 2016 Efraim Flashner <efraim@flashner.co.il>
@@ -62,35 +62,40 @@
#:use-module (srfi srfi-1))
(define-public libssh
- (package
- (name "libssh")
- (version "0.7.5")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "https://red.libssh.org/attachments/download/218/libssh-"
- version ".tar.xz"))
- (sha256
- (base32
- "15bh6dm9c50ndddzh3gqcgw7axp3ghrspjpkb1z3dr90vkanvs2l"))
- (patches (search-patches "libssh-hostname-parser-bug.patch"))))
- (build-system cmake-build-system)
- (outputs '("out" "debug"))
- (arguments
- '(#:configure-flags '("-DWITH_GCRYPT=ON")
-
- ;; TODO: Add 'CMockery' and '-DWITH_TESTING=ON' for the test suite.
- #:tests? #f))
- (inputs `(("zlib" ,zlib)
- ("libgcrypt" ,libgcrypt)))
- (synopsis "SSH client library")
- (description
- "libssh is a C library implementing the SSHv2 and SSHv1 protocol for
+ ;; This commit from the 'v0-7' branch contains 7 memory-management-related
+ ;; bug fixes that we'd rather have.
+ (let ((commit "239d0f75b5f909174c2ef7fb08d23bcfa6b20ba0")
+ (revision "0"))
+ (package
+ (name "libssh")
+ (version (git-version "0.7.5" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.libssh.org/projects/libssh.git")
+ (commit commit)))
+ (sha256
+ (base32
+ "01w72w1jsgs9ilj3n1gp6qkmdxr9n74i5h2nipi3x1vzm7bv8na1"))
+ (patches (search-patches "libssh-hostname-parser-bug.patch"))
+ (file-name (git-file-name name version))))
+ (build-system cmake-build-system)
+ (outputs '("out" "debug"))
+ (arguments
+ '(#:configure-flags '("-DWITH_GCRYPT=ON")
+
+ ;; TODO: Add 'CMockery' and '-DWITH_TESTING=ON' for the test suite.
+ #:tests? #f))
+ (inputs `(("zlib" ,zlib)
+ ("libgcrypt" ,libgcrypt)))
+ (synopsis "SSH client library")
+ (description
+ "libssh is a C library implementing the SSHv2 and SSHv1 protocol for
client and server implementations. With libssh, you can remotely execute
programs, transfer files, and use a secure and transparent tunnel for your
remote applications.")
- (home-page "https://www.libssh.org")
- (license license:lgpl2.1+)))
+ (home-page "https://www.libssh.org")
+ (license license:lgpl2.1+))))
(define-public libssh2
(package