summaryrefslogtreecommitdiff
path: root/gnu/packages/ssh.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-10-04 02:06:49 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-10-04 13:31:35 +0200
commitec7bcdc35af17021a9dfd73ef49750d0ad82b989 (patch)
tree96e43b0935c44dbd177ae7084dc50564adf39734 /gnu/packages/ssh.scm
parent3235a54cd762fc3ff512d4b38c10823ba0b5a8f2 (diff)
downloadguix-patches-ec7bcdc35af17021a9dfd73ef49750d0ad82b989.tar
guix-patches-ec7bcdc35af17021a9dfd73ef49750d0ad82b989.tar.gz
gnu: openssh: Remove empty /var/empty.
* gnu/packages/ssh.scm (openssh)[arguments]: Delete /var/empty after ‘make install’. Make the rest less repetitive—no functional changes.
Diffstat (limited to 'gnu/packages/ssh.scm')
-rw-r--r--gnu/packages/ssh.scm24
1 files changed, 13 insertions, 11 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 2240811be9..f7e6286db0 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -256,17 +256,19 @@ a server that supports the SSH-2 protocol.")
(("^(tests:.*) t-exec(.*)" all pre post)
(string-append pre post)))))
(replace 'install
- (lambda* (#:key outputs (make-flags '()) #:allow-other-keys)
- ;; Install without host keys and system configuration files.
- (apply invoke "make" "install-nosysconf" make-flags)
- (install-file "contrib/ssh-copy-id"
- (string-append (assoc-ref outputs "out")
- "/bin/"))
- (chmod (string-append (assoc-ref outputs "out")
- "/bin/ssh-copy-id") #o555)
- (install-file "contrib/ssh-copy-id.1"
- (string-append (assoc-ref outputs "out")
- "/share/man/man1/")))))))
+ (lambda* (#:key outputs (make-flags '()) #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ ;; Install without host keys and system configuration files.
+ (apply invoke "make" "install-nosysconf" make-flags)
+ (with-directory-excursion out
+ (rmdir "var/empty")
+ (rmdir "var"))
+ (with-directory-excursion "contrib"
+ (chmod "ssh-copy-id" #o555)
+ (install-file "ssh-copy-id"
+ (string-append out "/bin/"))
+ (install-file "ssh-copy-id.1"
+ (string-append out "/share/man/man1/")))))))))
(synopsis "Client and server for the secure shell (ssh) protocol")
(description
"The SSH2 protocol implemented in OpenSSH is standardised by the