summaryrefslogtreecommitdiff
path: root/gnu/packages/ssh.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2018-11-13 11:43:16 -0500
committerLeo Famulari <leo@famulari.name>2018-11-13 11:43:35 -0500
commitd5401375099f6e4562b849121265bb1c3e85874f (patch)
tree0b03ad96d3dbdea80a297774bdf2fc256b3eb668 /gnu/packages/ssh.scm
parent978d59737acaadbb0d2aa02ed071bb5d3f555973 (diff)
downloadguix-patches-d5401375099f6e4562b849121265bb1c3e85874f.tar
guix-patches-d5401375099f6e4562b849121265bb1c3e85874f.tar.gz
gnu: libssh: Fetch source over HTTPS.
* gnu/packages/ssh.scm (libssh)[source]: Use HTTPS URL.
Diffstat (limited to 'gnu/packages/ssh.scm')
-rw-r--r--gnu/packages/ssh.scm8
1 files changed, 1 insertions, 7 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 80564a9e19..5ea5148cbc 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -71,13 +71,7 @@
(source (origin
(method git-fetch)
(uri (git-reference
- ;; git.libssh.org does not support the fast "smart" HTTP
- ;; Git protocol. The "dumb" HTTP Git protocol is extremely
- ;; slow, and does not support shallow clones, so we use the
- ;; plain Git protocol despite its flaws. This offers an
- ;; incredible speedup and reduces the size of the the
- ;; source by more than half.
- (url "git://git.libssh.org/projects/libssh.git")
+ (url "https://git.libssh.org/projects/libssh.git")
(commit (string-append "libssh-" version))))
(patches (search-patches "libssh-hostname-parser-bug.patch"))
(sha256