summaryrefslogtreecommitdiff
path: root/gnu/packages/ssh.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2018-04-04 00:59:48 -0400
committerLeo Famulari <leo@famulari.name>2018-04-05 11:51:55 -0400
commitd355245030d9e1b74782eb21b56dbebae958b329 (patch)
treeeeda6cf2798a0b407ca5e579c1c8f57f8854692c /gnu/packages/ssh.scm
parent6de2af288fb6fecf46cca93290e1d04cddf83e48 (diff)
downloadguix-patches-d355245030d9e1b74782eb21b56dbebae958b329.tar
guix-patches-d355245030d9e1b74782eb21b56dbebae958b329.tar.gz
gnu: openssh: Update to 7.7p1.
* gnu/packages/ssh.scm (openssh): Update to 7.7p1. [arguments]: Set the test suite's working directory in #:make-flags.
Diffstat (limited to 'gnu/packages/ssh.scm')
-rw-r--r--gnu/packages/ssh.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 9d5fc2690d..afd41cd8e7 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -135,14 +135,14 @@ a server that supports the SSH-2 protocol.")
(define-public openssh
(package
(name "openssh")
- (version "7.6p1")
+ (version "7.7p1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://openbsd/OpenSSH/portable/"
name "-" version ".tar.gz"))
(sha256
(base32
- "08qpsb8mrzcx8wgvz9insiyvq7sbg26yj5nvl2m5n57yvppcl8x3"))))
+ "13vbbrvj3mmfhj83qyrg5c0ipr6bzw5s65dy4k8gr7p9hkkfffyp"))))
(build-system gnu-build-system)
(native-inputs `(("groff" ,groff)))
(inputs `(("openssl" ,openssl)
@@ -152,6 +152,9 @@ a server that supports the SSH-2 protocol.")
("xauth" ,xauth))) ;for 'ssh -X' and 'ssh -Y'
(arguments
`(#:test-target "tests"
+ ;; Otherwise, the test scripts try to use a nonexistent directory and
+ ;; fail.
+ #:make-flags '("REGRESSTMP=\"$${BUILDDIR}/regress\"")
#:configure-flags `("--sysconfdir=/etc/ssh"
;; Default value of 'PATH' used by sshd.