summaryrefslogtreecommitdiff
path: root/gnu/packages/ssh.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-03-21 19:14:18 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-03-21 19:23:47 +0100
commitc1f4e6491cecc5d121ef371a8fb2aa0a07030d36 (patch)
treebb4b7ef154cf0b7c84d118aed0273d0ba755a506 /gnu/packages/ssh.scm
parentaf8f7eb4f2a664c2d0fb3faabaf2e80c72993ef6 (diff)
downloadguix-patches-c1f4e6491cecc5d121ef371a8fb2aa0a07030d36.tar
guix-patches-c1f4e6491cecc5d121ef371a8fb2aa0a07030d36.tar.gz
gnu: curl: Restore derivation.
Commit af8f7eb4f2a664c2d0fb3faabaf2e80c72993ef6 accidentally changed the cURL derivation. Remove use of HIDDEN-PACKAGE and restore input order to prevent a large number of rebuilds. * gnu/packages/ssh.scm (libssh2-1.8.0): Move from here ... * gnu/packages/curl.scm (libssh2-1.8.0): ... to here. Don't use HIDDEN-PACKAGE and make it non-public. (curl)[inputs]: Move LIBSSH2-1.8.0 where it was before af8f7eb4f2a66.
Diffstat (limited to 'gnu/packages/ssh.scm')
-rw-r--r--gnu/packages/ssh.scm18
1 files changed, 0 insertions, 18 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 5b5890aae6..a75096b779 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -143,24 +143,6 @@ a server that supports the SSH-2 protocol.")
(license license:bsd-3)
(home-page "https://www.libssh2.org/")))
-;; XXX A hidden special obsolete libssh2 for temporary use in the curl package.
-;; <https://bugs.gnu.org/34927>
-(define-public libssh2-1.8.0
- (hidden-package
- (package
- (inherit libssh2)
- (version "1.8.0")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "https://www.libssh2.org/download/libssh2-"
- version ".tar.gz"))
- (sha256
- (base32
- "1m3n8spv79qhjq4yi0wgly5s5rc8783jb1pyra9bkx1md0plxwrr"))
- (patches
- (search-patches "libssh2-fix-build-failure-with-gcrypt.patch")))))))
-
(define-public openssh
(package
(name "openssh")