summaryrefslogtreecommitdiff
path: root/gnu/packages/ssh.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-05-22 02:00:01 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2022-05-22 02:00:07 +0200
commitb8d5cbb767d587e39fc3537a8606c872948ed192 (patch)
treeaf53d98cb33eed907589860c2868aaeb83ba16af /gnu/packages/ssh.scm
parent921b6f07faeae692b62fa929c05cb172e237da23 (diff)
downloadguix-patches-b8d5cbb767d587e39fc3537a8606c872948ed192.tar
guix-patches-b8d5cbb767d587e39fc3537a8606c872948ed192.tar.gz
gnu: hss: Update to 1.9.
* gnu/packages/ssh.scm (hss): Update to 1.9. [arguments]: Don't explicitly return #t from phases.
Diffstat (limited to 'gnu/packages/ssh.scm')
-rw-r--r--gnu/packages/ssh.scm9
1 files changed, 4 insertions, 5 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 7f3b02013e..58dd55de2a 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -80,16 +80,16 @@
(define-public hss
(package
(name "hss")
- (version "1.8")
+ (version "1.9")
(source (origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/six-ddc/hss")
- (commit (string-append "v" version))))
+ (commit version)))
(file-name (git-file-name name version))
(sha256
(base32
- "1rpysj65j9ls30bf2c5k5hykzzjfknrihs58imp178bx1wqzw4jl"))))
+ "12578xhvkg70ma411yh8nbpcpnys420bnm9g0dzypb0vn3jxpz8q"))))
(inputs
(list readline))
(arguments
@@ -103,8 +103,7 @@
(lambda* (#:key inputs outputs #:allow-other-keys)
(substitute* "Makefile"
(("/usr/local/opt/readline")
- (assoc-ref inputs "readline")))
- #t))
+ (assoc-ref inputs "readline")))))
(delete 'configure)))) ; no configure script
(build-system gnu-build-system)
(home-page "https://github.com/six-ddc/hss/")