summaryrefslogtreecommitdiff
path: root/gnu/packages/ssh.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-11-27 10:57:03 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-11-30 14:58:43 +0100
commita9ee11d5ab61d6dd64113d71c5a9c8511c1d050d (patch)
tree51efbdd7ffa003cf10f9d0bc9e5fac92562c201d /gnu/packages/ssh.scm
parent70b002aa1d721b207879a3e4a0fa33e7f302d723 (diff)
downloadguix-patches-a9ee11d5ab61d6dd64113d71c5a9c8511c1d050d.tar
guix-patches-a9ee11d5ab61d6dd64113d71c5a9c8511c1d050d.tar.gz
gnu: openssh: Use modify-phases syntax.
* gnu/packages/ssh.scm (openssh)[arguments]: Use modify-phases syntax.
Diffstat (limited to 'gnu/packages/ssh.scm')
-rw-r--r--gnu/packages/ssh.scm39
1 files changed, 19 insertions, 20 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 2f4f8a28a9..26729ea909 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -129,26 +129,25 @@ a server that supports the SSH-2 protocol.")
(arguments
`(#:test-target "tests"
#:phases
- (alist-cons-after
- 'configure 'reset-/var/empty
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (substitute* "Makefile"
- (("PRIVSEP_PATH=/var/empty")
- (string-append "PRIVSEP_PATH=" out "/var/empty")))))
- (alist-cons-before
- 'check 'patch-tests
- (lambda _
- ;; remove 't-exec' regress target which requires user 'sshd'
- (substitute* "regress/Makefile"
- (("^(REGRESS_TARGETS=.*) t-exec(.*)" all pre post)
- (string-append pre post))))
- (alist-replace
- 'install
- (lambda* (#:key (make-flags '()) #:allow-other-keys)
- ;; install without host keys and system configuration files
- (zero? (apply system* "make" "install-nosysconf" make-flags)))
- %standard-phases)))))
+ (modify-phases %standard-phases
+ (add-after 'configure 'reset-/var/empty
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (substitute* "Makefile"
+ (("PRIVSEP_PATH=/var/empty")
+ (string-append "PRIVSEP_PATH=" out "/var/empty")))
+ #t)))
+ (add-before 'check 'patch-tests
+ (lambda _
+ ;; remove 't-exec' regress target which requires user 'sshd'
+ (substitute* "regress/Makefile"
+ (("^(REGRESS_TARGETS=.*) t-exec(.*)" all pre post)
+ (string-append pre post)))
+ #t))
+ (replace 'install
+ (lambda* (#:key (make-flags '()) #:allow-other-keys)
+ ;; install without host keys and system configuration files
+ (zero? (apply system* "make" "install-nosysconf" make-flags)))))))
(synopsis "Client and server for the secure shell (ssh) protocol")
(description
"The SSH2 protocol implemented in OpenSSH is standardised by the